aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-05-06 22:30:38 +0800
committerak <ak@FreeBSD.org>2012-05-06 22:30:38 +0800
commit0b8cf4a0cbe315b4665c1eaa7ecb7dc82794c1a0 (patch)
treefd6bc462193bf02c7b2cae3dbb76f19e81544293 /graphics
parentc87fb13f7bef5c8c3b3c8b3d494aabe3622c0cf5 (diff)
downloadfreebsd-ports-graphics-0b8cf4a0cbe315b4665c1eaa7ecb7dc82794c1a0.tar.gz
freebsd-ports-graphics-0b8cf4a0cbe315b4665c1eaa7ecb7dc82794c1a0.tar.zst
freebsd-ports-graphics-0b8cf4a0cbe315b4665c1eaa7ecb7dc82794c1a0.zip
The Founts is a demo/program, which was inspired by Eric's Cascade.
PR: ports/167497 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler (mentor)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/founts/Makefile40
-rw-r--r--graphics/founts/distinfo2
-rw-r--r--graphics/founts/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2846a6c78c1..e7fdcf42926 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -196,6 +196,7 @@
SUBDIR += fortytwo
SUBDIR += fotofix
SUBDIR += fotoxx
+ SUBDIR += founts
SUBDIR += fpc-cairo
SUBDIR += fpc-fpgtk
SUBDIR += fpc-fpvectorial
diff --git a/graphics/founts/Makefile b/graphics/founts/Makefile
new file mode 100644
index 00000000000..8874e9456e8
--- /dev/null
+++ b/graphics/founts/Makefile
@@ -0,0 +1,40 @@
+# New Ports collection makefile for: founts
+# Date created: 2012-05-01
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= founts
+PORTVERSION= 12
+CATEGORIES= graphics games
+MASTER_SITES= http://www.linuxmotors.com/founts/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= A demo/program inspired by Erics cascade
+
+LICENSE= GPLv2
+
+USE_SDL= sdl
+
+PLIST_FILES= bin/founts
+
+PORTDOCS= Changelog README
+
+do-build:
+ cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
+ -lm `${SDL_CONFIG} --cflags --libs` founts.c
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/founts/distinfo b/graphics/founts/distinfo
new file mode 100644
index 00000000000..c6a59688bef
--- /dev/null
+++ b/graphics/founts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (founts-12.tgz) = 46da7a97eef91c162c946914dc81ab523963b4a5faebdf2bfd8482f32a485a8a
+SIZE (founts-12.tgz) = 21447
diff --git a/graphics/founts/pkg-descr b/graphics/founts/pkg-descr
new file mode 100644
index 00000000000..95ab0dd3774
--- /dev/null
+++ b/graphics/founts/pkg-descr
@@ -0,0 +1,3 @@
+The Founts is a demo/program, which was inspired by Eric's Cascade.
+
+WWW: http://www.linuxmotors.com/founts/