aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-25 23:37:52 +0800
committermiwi <miwi@FreeBSD.org>2008-04-25 23:37:52 +0800
commit1d78c42ff73c3b2475bc89c633cae44523b9f652 (patch)
tree01c0c00e51661b6ae5ceeb99abd1018b37379d5d /graphics
parent74f0d4fac25d2bf10f1d0f7224c6882c47dffc1f (diff)
downloadfreebsd-ports-graphics-1d78c42ff73c3b2475bc89c633cae44523b9f652.tar.gz
freebsd-ports-graphics-1d78c42ff73c3b2475bc89c633cae44523b9f652.tar.zst
freebsd-ports-graphics-1d78c42ff73c3b2475bc89c633cae44523b9f652.zip
Structure Synth is an application for creating 3D structures from
a set of user specified rules. It is an attempt to make a 3D version of Context Free. The resulting structures can be viewed in the integrated OpenGL viewer or exported to various formats. WWW: http://structuresynth.sourceforge.net PR: ports/122897 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/structuresynth/Makefile41
-rw-r--r--graphics/structuresynth/distinfo3
-rw-r--r--graphics/structuresynth/pkg-descr6
-rw-r--r--graphics/structuresynth/pkg-plist36
5 files changed, 87 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d0b13d4cde3..3413b04d0b3 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -719,6 +719,7 @@
SUBDIR += sswf
SUBDIR += stamp
SUBDIR += stl2pov
+ SUBDIR += structuresynth
SUBDIR += svg2pdf
SUBDIR += svg2png
SUBDIR += svg2swf
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
new file mode 100644
index 00000000000..1a5396c7c62
--- /dev/null
+++ b/graphics/structuresynth/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: structuresynth
+# Date created: 06 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= structuresynth
+PORTVERSION= 0.7.0
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= StructureSynth-Source-v${PORTVERSION}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Rule-based 3D structure generator
+
+USE_ZIP= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake corelib gui opengl moc rcc
+
+WRKSRC= ${WRKDIR}/source/trunk
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"Examples"|"${DATADIR}/Examples"|; \
+ s|"Misc"|"${DATADIR}/Misc"|' ${WRKSRC}/MainWindow.cpp
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ -project
+ @${ECHO_CMD} "QT+=opengl" >> ${WRKSRC}/trunk.pro
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ -spec ${QMAKESPEC} trunk.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/trunk ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}/Examples
+ ${INSTALL_DATA} ${WRKSRC}/Examples/*.es ${DATADIR}/Examples
+ ${MKDIR} ${DATADIR}/Misc
+ ${INSTALL_DATA} ${WRKSRC}/Misc/* ${DATADIR}/Misc
+
+.include <bsd.port.mk>
diff --git a/graphics/structuresynth/distinfo b/graphics/structuresynth/distinfo
new file mode 100644
index 00000000000..687e188a011
--- /dev/null
+++ b/graphics/structuresynth/distinfo
@@ -0,0 +1,3 @@
+MD5 (StructureSynth-Source-v0.7.0.zip) = f1ab047748af3d686e7263d11f5dbb20
+SHA256 (StructureSynth-Source-v0.7.0.zip) = 07fb7034c9201deaeb486a365263e5cd462bb6dcea8bb2f0b7f40fc1d5547050
+SIZE (StructureSynth-Source-v0.7.0.zip) = 690193
diff --git a/graphics/structuresynth/pkg-descr b/graphics/structuresynth/pkg-descr
new file mode 100644
index 00000000000..adf24d1a4d6
--- /dev/null
+++ b/graphics/structuresynth/pkg-descr
@@ -0,0 +1,6 @@
+Structure Synth is an application for creating 3D structures from
+a set of user specified rules. It is an attempt to make a 3D version
+of Context Free. The resulting structures can be viewed in the
+integrated OpenGL viewer or exported to various formats.
+
+WWW: http://structuresynth.sourceforge.net
diff --git a/graphics/structuresynth/pkg-plist b/graphics/structuresynth/pkg-plist
new file mode 100644
index 00000000000..9d006dbd471
--- /dev/null
+++ b/graphics/structuresynth/pkg-plist
@@ -0,0 +1,36 @@
+bin/structuresynth
+%%DATADIR%%/Examples/Arc Sphere.es
+%%DATADIR%%/Examples/Ball.es
+%%DATADIR%%/Examples/Binary Circle.es
+%%DATADIR%%/Examples/BinaryKite.es
+%%DATADIR%%/Examples/Boxes II.es
+%%DATADIR%%/Examples/Chaos II.es
+%%DATADIR%%/Examples/City of Glass.es
+%%DATADIR%%/Examples/Colors.es
+%%DATADIR%%/Examples/Colorspyro.es
+%%DATADIR%%/Examples/Colorspyro2.es
+%%DATADIR%%/Examples/Default.es
+%%DATADIR%%/Examples/Defunct Tech.es
+%%DATADIR%%/Examples/Frame In Frame.es
+%%DATADIR%%/Examples/Grid.es
+%%DATADIR%%/Examples/Grinder.es
+%%DATADIR%%/Examples/Jugend2D.es
+%%DATADIR%%/Examples/Menger.es
+%%DATADIR%%/Examples/Menger2.es
+%%DATADIR%%/Examples/Menger3.es
+%%DATADIR%%/Examples/Mondrian.es
+%%DATADIR%%/Examples/Octopod II.es
+%%DATADIR%%/Examples/Quartz.es
+%%DATADIR%%/Examples/Snakeoids.es
+%%DATADIR%%/Examples/SpiralTree2D.es
+%%DATADIR%%/Examples/Stairs.es
+%%DATADIR%%/Examples/Torus2.es
+%%DATADIR%%/Examples/Torus3.es
+%%DATADIR%%/Examples/Trees 2d.es
+%%DATADIR%%/Examples/Trees 3d.es
+%%DATADIR%%/Examples/Tube.es
+%%DATADIR%%/Misc/about.html
+%%DATADIR%%/Misc/icon.jpg
+@dirrm %%DATADIR%%/Misc
+@dirrm %%DATADIR%%/Examples
+@dirrm %%DATADIR%%