aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-14 06:26:40 +0800
committerpav <pav@FreeBSD.org>2003-12-14 06:26:40 +0800
commit1f84d3e24530c865a1eef17b431184830b75d730 (patch)
tree22f46afaa40c700544e18bf0cc083148f40986e4 /graphics
parente19c39e49e54a6f62d6974c9461bbc34b92d6c82 (diff)
downloadfreebsd-ports-graphics-1f84d3e24530c865a1eef17b431184830b75d730.tar.gz
freebsd-ports-graphics-1f84d3e24530c865a1eef17b431184830b75d730.tar.zst
freebsd-ports-graphics-1f84d3e24530c865a1eef17b431184830b75d730.zip
Add dvipng, a DVI to PNG converter.
PR: ports/60191 Submitted by: o_sleep <o_sleep@babbleheaven.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dvipng/Makefile29
-rw-r--r--graphics/dvipng/distinfo1
-rw-r--r--graphics/dvipng/pkg-descr4
-rw-r--r--graphics/dvipng/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b6e63234736..f5f7fd3efdd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -48,6 +48,7 @@
SUBDIR += dri-devel
SUBDIR += drm-kmod
SUBDIR += duhdraw
+ SUBDIR += dvipng
SUBDIR += dynamechs
SUBDIR += ecg2png
SUBDIR += electriceyes
diff --git a/graphics/dvipng/Makefile b/graphics/dvipng/Makefile
new file mode 100644
index 00000000000..e669d8a95cf
--- /dev/null
+++ b/graphics/dvipng/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: dvipng
+# Date created: Dec 9, 2003
+# Whom: o_sleep
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvipng
+PORTVERSION= 0.8
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= preview-latex
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= DVI to PNG Converter
+
+BUILD_DEPENDS= kpsepath:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+
+INFO= dvipng
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/graphics/dvipng/distinfo b/graphics/dvipng/distinfo
new file mode 100644
index 00000000000..e8f47afb124
--- /dev/null
+++ b/graphics/dvipng/distinfo
@@ -0,0 +1 @@
+MD5 (dvipng-0.8.tar.gz) = c0b3deaa46cf22b59a65596578103322
diff --git a/graphics/dvipng/pkg-descr b/graphics/dvipng/pkg-descr
new file mode 100644
index 00000000000..0f70df30144
--- /dev/null
+++ b/graphics/dvipng/pkg-descr
@@ -0,0 +1,4 @@
+This program makes PNG graphics from DVI files as obtained from TeX
+and its relatives.
+
+WWW: http://sourceforge.net/projects/preview-latex/
diff --git a/graphics/dvipng/pkg-plist b/graphics/dvipng/pkg-plist
new file mode 100644
index 00000000000..ab50bf90e14
--- /dev/null
+++ b/graphics/dvipng/pkg-plist
@@ -0,0 +1 @@
+bin/dvipng