aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-06 05:47:23 +0800
committerpav <pav@FreeBSD.org>2005-02-06 05:47:23 +0800
commit1fd8caef06e8d758d114d9dac8790b70f3f32bdd (patch)
tree9925da5b32727d74f2451714e002984b737de2d2 /graphics
parent93f2909a13532a1131d11ca194250e4c0fda65fb (diff)
downloadfreebsd-ports-graphics-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.tar.gz
freebsd-ports-graphics-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.tar.zst
freebsd-ports-graphics-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.zip
Sage is an OpenGL extension library written to make use of SDL's mechanism for
enabling OpenGL's extensions. PR: ports/77088 Submitted by: Jan Rochel <jannisan@t-online.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/sage/Makefile31
-rw-r--r--graphics/sage/distinfo2
-rw-r--r--graphics/sage/files/patch-Makefile.in19
-rw-r--r--graphics/sage/pkg-descr7
-rw-r--r--graphics/sage/pkg-plist11
6 files changed, 71 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6f63418754d..85714caf49e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -454,6 +454,7 @@
SUBDIR += rubyphoto
SUBDIR += s10sh
SUBDIR += s3switch
+ SUBDIR += sage
SUBDIR += sam2p
SUBDIR += sane-backends
SUBDIR += sane-frontends
diff --git a/graphics/sage/Makefile b/graphics/sage/Makefile
new file mode 100644
index 00000000000..26010206f38
--- /dev/null
+++ b/graphics/sage/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: sage
+# Date created: 4 February 2005
+# Whom: Janni
+#
+# $FreeBSD$
+#
+
+PORTNAME= sage
+PORTVERSION= 0.1.1
+CATEGORIES= graphics devel
+MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/sage/ \
+ http://purple.worldforge.org/downloads/libs/sage/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= worldforge
+
+MAINTAINER= jannisan@t-online.de
+COMMENT= OpenGL extension library
+
+USE_SDL= sdl
+USE_GL= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+CFLAGS= -I${X11BASE}/include
+CONFIGURE_ENV= "CFLAGS=${CFLAGS}"
+
+post-patch:
+ ${REINPLACE_CMD} s/sdl-config/sdl11-config/g ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/sage/distinfo b/graphics/sage/distinfo
new file mode 100644
index 00000000000..f564b0bcb01
--- /dev/null
+++ b/graphics/sage/distinfo
@@ -0,0 +1,2 @@
+MD5 (sage-0.1.1.tar.gz) = 6443d9bfc5fed7da5608b05f40c9fc0d
+SIZE (sage-0.1.1.tar.gz) = 403561
diff --git a/graphics/sage/files/patch-Makefile.in b/graphics/sage/files/patch-Makefile.in
new file mode 100644
index 00000000000..86bf602da8d
--- /dev/null
+++ b/graphics/sage/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+*** Makefile.in.orig Fri Feb 4 05:47:36 2005
+--- Makefile.in Fri Feb 4 05:47:48 2005
+***************
+*** 169,175 ****
+
+ EXTRA_DIST = sage.spec sage.pc autogen.sh build_sage.pl
+
+! pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = sage.pc
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+--- 169,175 ----
+
+ EXTRA_DIST = sage.spec sage.pc autogen.sh build_sage.pl
+
+! pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = sage.pc
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/graphics/sage/pkg-descr b/graphics/sage/pkg-descr
new file mode 100644
index 00000000000..72f3107203d
--- /dev/null
+++ b/graphics/sage/pkg-descr
@@ -0,0 +1,7 @@
+Sage is an OpenGL extension library written to make use of SDL's mechanism for
+enabling OpenGL's extensions.
+
+WWW: http://www.worldforge.org/dev/eng/libraries/sage
+
+- Janni
+jannisan@t-online.de
diff --git a/graphics/sage/pkg-plist b/graphics/sage/pkg-plist
new file mode 100644
index 00000000000..dd12db70085
--- /dev/null
+++ b/graphics/sage/pkg-plist
@@ -0,0 +1,11 @@
+lib/libsage.a
+lib/libsage.so
+lib/libsage.so.0
+include/sage/sage.h
+include/sage/utility.h
+include/sage/glext_sage.h
+include/sage/GL.h
+include/sage/GLU.h
+include/sage/header.h
+@dirrm include/sage
+libdata/pkgconfig/sage.pc