aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-06-13 22:04:39 +0800
committergahr <gahr@FreeBSD.org>2008-06-13 22:04:39 +0800
commit3a0c843e503e6e98dd4a02ed91706a15c6882373 (patch)
tree154eae77142d0b5e0e6d5e6bbc0c62b565be32b9 /graphics
parentb0fb24467ea9e7a1b39d82cff35a40cecd5e49fd (diff)
downloadfreebsd-ports-graphics-3a0c843e503e6e98dd4a02ed91706a15c6882373.tar.gz
freebsd-ports-graphics-3a0c843e503e6e98dd4a02ed91706a15c6882373.tar.zst
freebsd-ports-graphics-3a0c843e503e6e98dd4a02ed91706a15c6882373.zip
- Unbreak on amd64
- Fix on sparc64 - Move pkg-plist to PLIST_FILES - Take maintainship
Diffstat (limited to 'graphics')
-rw-r--r--graphics/freeimage/Makefile13
-rw-r--r--graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp20
-rw-r--r--graphics/freeimage/pkg-plist4
3 files changed, 26 insertions, 11 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index f00d8a475da..e1b9791e2ba 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= FreeImage${PORTVERSION:S/.//g}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= An open source graphics library
WRKSRC= ${WRKDIR}/FreeImage
@@ -22,10 +22,9 @@ USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -qoa
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+PLIST_FILES= include/FreeImage.h \
+ lib/libfreeimage.a \
+ lib/libfreeimage.so \
+ lib/libfreeimage.so.3
-.if ${ARCH} == "amd64"
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp b/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp
new file mode 100644
index 00000000000..619c057fdf8
--- /dev/null
+++ b/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp
@@ -0,0 +1,20 @@
+--- Source/FreeImage/PluginBMP.cpp.orig 2008-06-13 00:40:16.000000000 +0200
++++ Source/FreeImage/PluginBMP.cpp 2008-06-13 00:46:51.000000000 +0200
+@@ -224,7 +224,7 @@
+ throw(1);
+ }
+ if (status_byte != 0) {
+- status_byte = MIN(status_byte, end - q);
++ status_byte = MIN((size_t)status_byte, (size_t)(end - q));
+ // Encoded mode
+ if(io->read_proc(&second_byte, sizeof(BYTE), 1, handle) != 1) {
+ throw(1);
+@@ -279,7 +279,7 @@
+ default:
+ {
+ // Absolute mode
+- status_byte = MIN(status_byte, end - q);
++ status_byte = MIN((size_t)status_byte, (size_t)(end - q));
+ for (int i = 0; i < status_byte; i++) {
+ if ((i & 0x01) == 0) {
+ if(io->read_proc(&second_byte, sizeof(BYTE), 1, handle) != 1) {
diff --git a/graphics/freeimage/pkg-plist b/graphics/freeimage/pkg-plist
deleted file mode 100644
index 047ac8c88bf..00000000000
--- a/graphics/freeimage/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-include/FreeImage.h
-lib/libfreeimage.a
-lib/libfreeimage.so
-lib/libfreeimage.so.3