aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-18 02:28:12 +0800
committerknu <knu@FreeBSD.org>2001-09-18 02:28:12 +0800
commit3f4ffff96b114333af00c98ee270871d67ab45eb (patch)
tree615e48a09ce9966594b84ed7a7d57de5689ab07f /graphics
parentf611dc744c9aabc57ba1e71f86d7583eb06ae043 (diff)
downloadfreebsd-ports-graphics-3f4ffff96b114333af00c98ee270871d67ab45eb.tar.gz
freebsd-ports-graphics-3f4ffff96b114333af00c98ee270871d67ab45eb.tar.zst
freebsd-ports-graphics-3f4ffff96b114333af00c98ee270871d67ab45eb.zip
Fix silly syntax bugs in ming.rb.
Reported by: Tom Hukins <tom@FreeBSD.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ruby-ming/Makefile2
-rw-r--r--graphics/ruby-ming/files/patch-ming.rb18
2 files changed, 19 insertions, 1 deletions
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index 28834af3915..1ea65b152ee 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ming
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics ruby
MASTER_SITES= # none
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/graphics/ruby-ming/files/patch-ming.rb b/graphics/ruby-ming/files/patch-ming.rb
new file mode 100644
index 00000000000..76f13f8b7e9
--- /dev/null
+++ b/graphics/ruby-ming/files/patch-ming.rb
@@ -0,0 +1,18 @@
+--- ming.rb.orig Mon Sep 17 20:48:39 2001
++++ ming.rb Tue Sep 18 03:22:32 2001
+@@ -344,6 +344,7 @@
+
+ # deprecated
+ class SWFMovieClip <SWFSprite
++end
+
+ class SWFGradient <SWFBase
+ def initialize
+@@ -375,6 +376,7 @@
+
+ # deprecated
+ class SWFMorphShape <SWFMorph
++end
+
+ class SWFFont <SWFBase
+