aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-05-25 07:53:38 +0800
committerwen <wen@FreeBSD.org>2011-05-25 07:53:38 +0800
commit5b732546c2f8ace3fb10df9d950c6ff7274555b7 (patch)
tree67f3cde0721c4c1d76c887d463d8380443a56722 /graphics
parentd3ffd232a613f8a77ce0c548e5734130ee1cfc57 (diff)
downloadfreebsd-ports-graphics-5b732546c2f8ace3fb10df9d950c6ff7274555b7.tar.gz
freebsd-ports-graphics-5b732546c2f8ace3fb10df9d950c6ff7274555b7.tar.zst
freebsd-ports-graphics-5b732546c2f8ace3fb10df9d950c6ff7274555b7.zip
- Update to 0.7.1 and unbreak
PR: ports/152220 Submitted by: Bartosz Fabianowski <freebsd@chillt.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapnik/Makefile40
-rw-r--r--graphics/mapnik/distinfo4
-rw-r--r--graphics/mapnik/pkg-plist4
3 files changed, 34 insertions, 14 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 46e6536ebf6..8a3f03b5890 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -6,43 +6,61 @@
#
PORTNAME= mapnik
-PORTVERSION= 0.6.1
-PORTREVISION= 5
+PORTVERSION= 0.7.1
CATEGORIES= graphics geography
MASTER_SITES= ${MASTER_SITE_BERLIOS}/${PORTNAME}/
MAINTAINER= wenheping@gmail.com
COMMENT= A Free Toolkit For Developing Mapping Applications
-LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
- proj:${PORTSDIR}/graphics/proj \
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
png:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
- cairo.2:${PORTSDIR}/graphics/cairo \
- iconv:${PORTSDIR}/converters/libiconv
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ icuuc:${PORTSDIR}/devel/icu \
+ boost_system:${PORTSDIR}/devel/boost-libs
BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
+ icu>=4.1.4:${PORTSDIR}/devel/icu \
${PYTHON_PKGNAMEPREFIX}icu>=0.8.1:${PORTSDIR}/devel/py-icu \
- ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo \
- ${LOCALBASE}/include/cairomm-1.0/cairomm/cairomm.h:${PORTSDIR}/graphics/cairomm \
+ boost-libs>1.41:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python-libs
-BROKEN= Does not build with boost-1.41
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_PGSQL= yes
USE_BZIP2= yes
-NO_BUILD= yes
USE_PYTHON= 2.5+
USE_LDCONFIG= yes
+USE_SCONS= yes
USE_AUTOTOOLS= libltdl
+USE_GNOME= pkgconfig libxml2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS= CAIRO "Enable cairo rendering" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_CAIRO)
+SCONS_ARGS+= CAIRO=False
+.else
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo \
+ cairomm-1.0:${PORTSDIR}/graphics/cairomm
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo
+.endif
+
.include <bsd.port.pre.mk>
+.if defined (MAKE_JOBS_NUMBER)
+SCONS_ARGS+= JOBS=${MAKE_JOBS_NUMBER}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
${WRKSRC}/SConstruct
do-install:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} scons/scons.py install
+ @cd ${INSTALL_WRKSRC} && ${SETENV} ${SCONS_BUILDENV} ${SCONS_BIN} \
+ ${SCONS_INSTALL_TARGET}
.include <bsd.port.post.mk>
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
index 453703239fe..39bc1bcc371 100644
--- a/graphics/mapnik/distinfo
+++ b/graphics/mapnik/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mapnik-0.6.1.tar.bz2) = 59b1c19817ed65ba8f0d3a2ac8f06ecf5c12f452d10170fa04f6824ea257437f
-SIZE (mapnik-0.6.1.tar.bz2) = 7466271
+SHA256 (mapnik-0.7.1.tar.bz2) = 0d04e8cbc2a060ce09ba13ccdcd7bf8bd02bed77a84a3dd1191e4d75fba95b8d
+SIZE (mapnik-0.7.1.tar.bz2) = 10021260
diff --git a/graphics/mapnik/pkg-plist b/graphics/mapnik/pkg-plist
index 7a0ed45e9e8..d26374af847 100644
--- a/graphics/mapnik/pkg-plist
+++ b/graphics/mapnik/pkg-plist
@@ -3,6 +3,7 @@ include/mapnik/boolean_filter.hpp
include/mapnik/font_set.hpp
include/mapnik/cairo_renderer.hpp
include/mapnik/version.hpp
+include/mapnik/wall_clock_timer.hpp
include/mapnik/wkb.hpp
include/mapnik/coord.hpp
include/mapnik/utils.hpp
@@ -30,7 +31,6 @@ include/mapnik/regex_filter.hpp
include/mapnik/libxml2_loader.hpp
include/mapnik/image_view.hpp
include/mapnik/feature_factory.hpp
-include/mapnik/local_datasource.hpp
include/mapnik/style_factory.hpp
include/mapnik/attribute_collector.hpp
include/mapnik/text_symbolizer.hpp
@@ -65,6 +65,7 @@ include/mapnik/color_factory.hpp
include/mapnik/plugin.hpp
include/mapnik/gamma.hpp
include/mapnik/feature.hpp
+include/mapnik/hextree.hpp
include/mapnik/hit_test_filter.hpp
include/mapnik/symbolizer.hpp
include/mapnik/png_io.hpp
@@ -105,6 +106,7 @@ lib/libmapnik.so.0
lib/mapnik/input/postgis.input
lib/mapnik/input/raster.input
lib/mapnik/input/shape.input
+lib/mapnik/fonts/unifont-5.1.20080907.ttf
lib/mapnik/fonts/DejaVuSerif-BoldItalic.ttf
lib/mapnik/fonts/DejaVuSerifCondensed-BoldItalic.ttf
lib/mapnik/fonts/DejaVuSerif-Italic.ttf