aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-09-15 23:22:13 +0800
committernork <nork@FreeBSD.org>2005-09-15 23:22:13 +0800
commit6ee611fb74adc8ddb2f3afba415042ad94ecadeb (patch)
tree869512f483cc614ae651005e9fc707af10c2dd84 /graphics
parent2959180666e758afe7506b6c0e6d2c6c01439a4a (diff)
downloadfreebsd-ports-graphics-6ee611fb74adc8ddb2f3afba415042ad94ecadeb.tar.gz
freebsd-ports-graphics-6ee611fb74adc8ddb2f3afba415042ad94ecadeb.tar.zst
freebsd-ports-graphics-6ee611fb74adc8ddb2f3afba415042ad94ecadeb.zip
Add exrtools 0.4, utilities for manipulating with HDR
images in OpenEXR format. PR: ports/84945 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/exrtools/Makefile60
-rw-r--r--graphics/exrtools/distinfo2
-rw-r--r--graphics/exrtools/pkg-descr18
4 files changed, 81 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7f608a20786..385c5b12e47 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -99,6 +99,7 @@
SUBDIR += exifprobe
SUBDIR += exiftags
SUBDIR += exiv2
+ SUBDIR += exrtools
SUBDIR += f-spot
SUBDIR += fbm
SUBDIR += feh
diff --git a/graphics/exrtools/Makefile b/graphics/exrtools/Makefile
new file mode 100644
index 00000000000..e1d046ff8af
--- /dev/null
+++ b/graphics/exrtools/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: exrtools
+# Date created: 15 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exrtools
+PORTVERSION= 0.4
+CATEGORIES= graphics
+MASTER_SITES= http://scanline.ca/exrtools/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Utilities for manipulating with HDR images in OpenEXR format
+
+LIB_DEPENDS= Half:${PORTSDIR}/graphics/OpenEXR \
+ png:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_LIBTOOL_VER=13
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/exrblur bin/exrchr bin/exricamtm bin/exrnlm \
+ bin/exrnormalize bin/exrpptm bin/exrstats \
+ bin/exrtopng bin/jpegtoexr bin/pngtoexr bin/ppmtoexr
+
+MAN1= exrblur.1 exrchr.1 exricamtm.1 exrnlm.1 exrnormalize.1 \
+ exrpptm.1 exrstats.1 exrtools.1 exrtopng.1 jpegtoexr.1 \
+ pngtoexr.1 ppmtoexr.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<values\.h>|<float.h>|' \
+ ${WRKSRC}/src/exrnormalize.c \
+ ${WRKSRC}/src/exrpptm.c \
+ ${WRKSRC}/src/exrstats.c
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|' \
+ ${WRKSRC}/src/exrblur.c \
+ ${WRKSRC}/src/exrchr.c \
+ ${WRKSRC}/src/exrnlm.c \
+ ${WRKSRC}/src/exrnormalize.c \
+ ${WRKSRC}/src/exrpptm.c \
+ ${WRKSRC}/src/ppmtoexr.c \
+ ${WRKSRC}/src/exricamtm.c \
+ ${WRKSRC}/src/jpeginput.h \
+ ${WRKSRC}/src/pngoutput.h \
+ ${WRKSRC}/src/pnginput.h
+ @${REINPLACE_CMD} -e 's|inttypes\.h|sys/types.h|' \
+ ${WRKSRC}/src/ppmtoexr.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/exrtools/distinfo b/graphics/exrtools/distinfo
new file mode 100644
index 00000000000..ae2d4fc33fe
--- /dev/null
+++ b/graphics/exrtools/distinfo
@@ -0,0 +1,2 @@
+MD5 (exrtools-0.4.tar.gz) = 8533e98f78f70d8180fe6865bc383f06
+SIZE (exrtools-0.4.tar.gz) = 300197
diff --git a/graphics/exrtools/pkg-descr b/graphics/exrtools/pkg-descr
new file mode 100644
index 00000000000..b25ea946bdc
--- /dev/null
+++ b/graphics/exrtools/pkg-descr
@@ -0,0 +1,18 @@
+exrtools is a set of simple command-line utilities for manipulating
+with high dynamic range images in OpenEXR format. OpenEXR is a high
+dynamic-range (HDR) image file format developed by Industrial Light
+& Magic for use in computer imaging applications.
+
+exrtools was developed to help experiment with batch processing of
+HDR images for tone mapping. Each application is small and
+reasonably self-contained such that the source code may be of most
+value to others.
+
+exrtools currently only works with RGBA OpenEXR files. As well, the
+code assumes that the EXR files and PNG files all use sRGB primaries
+and gamma function.
+
+WWW: http://scanline.ca/exrtools/
+
+- ehaupt
+ehaupt@critical.ch