aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-07-22 22:58:52 +0800
committermi <mi@FreeBSD.org>2002-07-22 22:58:52 +0800
commit778976c395d96756bb7855ccfae2ff9e27b53744 (patch)
tree9f8c9fca1e393d7916bb7ff2209dd4131a68ada4 /graphics
parentdec3459be2a552a8cae887bccf083988a6e0617e (diff)
downloadfreebsd-ports-graphics-778976c395d96756bb7855ccfae2ff9e27b53744.tar.gz
freebsd-ports-graphics-778976c395d96756bb7855ccfae2ff9e27b53744.tar.zst
freebsd-ports-graphics-778976c395d96756bb7855ccfae2ff9e27b53744.zip
Add the HAVE_* defines to CXXFLAGS as well as CFLAGS. Add -lstdc++ to
LDADD, which lead to the unfortunate PORTREVISION bump. PR: ports/40874 Submitted by: Jan Stocker
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libfpx/Makefile2
-rw-r--r--graphics/libfpx/files/Makefile.bsd4
2 files changed, 3 insertions, 3 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 2dfb5993b1d..ff04814faff 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libfpx
PORTVERSION= 1.2.0.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://imagemagick.sourceforge.net/http/delegates/ \
ftp://ftp.yggdrasil.com/mirrors/site/ftp.simplesystems.org/pub/%SUBDIR%/ \
@@ -31,7 +32,6 @@ MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
MAKE_ARGS+= -j2
-#CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index e0e1a639f8d..644dd0f77e8 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -24,8 +24,8 @@ CPPS += ${OLESS:S/^/${.CURDIR}\/oless\//} ${JPGS}
SRCS = ${CPPS:T}
-CXXFLAGS+= -fno-rtti -fno-exceptions
-LDADD += -L${LOCALBASE}/lib -ljpeg
+CXXFLAGS+= -fno-rtti -fno-exceptions -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
+LDADD += -L${LOCALBASE}/lib -ljpeg -lstdc++
.PATH: ${CPPS:H}