aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-11-16 16:52:11 +0800
committertg <tg@FreeBSD.org>1998-11-16 16:52:11 +0800
commit8afbdd19792577fca1211b02f337ef04cebd1584 (patch)
tree7a2d1e723c1de693ef2ed3478305f0fb18be6aa3 /graphics
parentafd92aa62d43a909bec7c7156435bc73338f1da5 (diff)
downloadfreebsd-ports-graphics-8afbdd19792577fca1211b02f337ef04cebd1584.tar.gz
freebsd-ports-graphics-8afbdd19792577fca1211b02f337ef04cebd1584.tar.zst
freebsd-ports-graphics-8afbdd19792577fca1211b02f337ef04cebd1584.zip
Install header files.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-imaging/Makefile6
-rw-r--r--graphics/py-imaging/pkg-plist3
2 files changed, 8 insertions, 1 deletions
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
index 5eac44c93bf..25bd15061c7 100644
--- a/graphics/py-imaging/Makefile
+++ b/graphics/py-imaging/Makefile
@@ -3,7 +3,7 @@
# Date created: 02 November 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.1.1.1 1998/11/05 08:02:39 tg Exp $
+# $Id: Makefile,v 1.2 1998/11/09 08:10:03 tg Exp $
#
DISTNAME= Imaging-0.3b2
@@ -31,6 +31,7 @@ PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
PILDIR= ${PYTHONSCRIPTDIR}/site-packages/PIL
PILDOCDIR= ${PREFIX}/share/doc/PIL
PILEXDIR= ${PREFIX}/share/examples/PIL
+PILINCDIR= ${PREFIX}/include/python1.5
TKINTERORIG= ${PYTHONSCRIPTDIR}/lib-dynload/_tkinter.so
post-extract:
@@ -61,5 +62,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../FORMATS ${PILDOCDIR}
@${MKDIR} ${PILEXDIR}
${INSTALL_DATA} ${WRKSRC}/../Scripts/* ${PILEXDIR}
+.for file in ImConfig.h ImPlatform.h Imaging.h
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PILINCDIR}
+.endfor
.include <bsd.port.mk>
diff --git a/graphics/py-imaging/pkg-plist b/graphics/py-imaging/pkg-plist
index 4e5349b212d..2fcc58002d5 100644
--- a/graphics/py-imaging/pkg-plist
+++ b/graphics/py-imaging/pkg-plist
@@ -1,3 +1,6 @@
+include/python1.5/ImConfig.h
+include/python1.5/ImPlatform.h
+include/python1.5/Imaging.h
lib/python1.5/site-packages/PIL/ArgImagePlugin.py
lib/python1.5/site-packages/PIL/ArgImagePlugin.pyc
lib/python1.5/site-packages/PIL/ArgImagePlugin.pyo