aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-03-10 09:13:57 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-03-10 09:13:57 +0800
commit8fd4ed0326d0affbc45846de1864540352ef1afc (patch)
tree261b3d4810ef91c2ae17b75f94bb0010eb959fbf /graphics
parent01a1fdb99ded8912a84b45111c51cf5bf99175a4 (diff)
downloadfreebsd-ports-graphics-8fd4ed0326d0affbc45846de1864540352ef1afc.tar.gz
freebsd-ports-graphics-8fd4ed0326d0affbc45846de1864540352ef1afc.tar.zst
freebsd-ports-graphics-8fd4ed0326d0affbc45846de1864540352ef1afc.zip
The ZBar Bar Code Reader is a library for scanning and decoding bar
codes from various sources such as video streams, image files or raw intensity sensors. It supports EAN, UPC, Code 128, Code 39 and Interleaved 2 of 5. These are the bindings for interacting directly with the library from Perl. WWW: http://search.cpan.org/dist/Barcode-ZBar/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Barcode-ZBar/Makefile21
-rw-r--r--graphics/p5-Barcode-ZBar/distinfo2
-rw-r--r--graphics/p5-Barcode-ZBar/pkg-descr9
-rw-r--r--graphics/p5-Barcode-ZBar/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cc4bafca534..51df916f643 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -622,6 +622,7 @@
SUBDIR += osgearth
SUBDIR += oyranos
SUBDIR += p5-Acme-Steganography-Image-Png
+ SUBDIR += p5-Barcode-ZBar
SUBDIR += p5-CAD-Drawing
SUBDIR += p5-CAD-Drawing-Template
SUBDIR += p5-Cairo
diff --git a/graphics/p5-Barcode-ZBar/Makefile b/graphics/p5-Barcode-ZBar/Makefile
new file mode 100644
index 00000000000..775f5272d6b
--- /dev/null
+++ b/graphics/p5-Barcode-ZBar/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Barcode-ZBar
+PORTVERSION= 0.04
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to ZBar barcode reader
+
+LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
+
+USES= perl5
+USE_PERL5= configure
+CONFIGURE_ARGS= INC="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+pre-install:
+ ${STRIP_CMD} ${WRKSRC}/blib/arch/auto/Barcode/ZBar/ZBar.so
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Barcode-ZBar/distinfo b/graphics/p5-Barcode-ZBar/distinfo
new file mode 100644
index 00000000000..309985a9907
--- /dev/null
+++ b/graphics/p5-Barcode-ZBar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Barcode-ZBar-0.04.tar.gz) = d57e1ad471b6a29fa4134650e6eec9eb834d42cbe8bf8f0608c67d6dd0f8f431
+SIZE (Barcode-ZBar-0.04.tar.gz) = 57582
diff --git a/graphics/p5-Barcode-ZBar/pkg-descr b/graphics/p5-Barcode-ZBar/pkg-descr
new file mode 100644
index 00000000000..22ea623b8d7
--- /dev/null
+++ b/graphics/p5-Barcode-ZBar/pkg-descr
@@ -0,0 +1,9 @@
+The ZBar Bar Code Reader is a library for scanning and decoding bar
+codes from various sources such as video streams, image files or raw
+intensity sensors. It supports EAN, UPC, Code 128, Code 39 and
+Interleaved 2 of 5.
+
+These are the bindings for interacting directly with the library from
+Perl.
+
+WWW: http://search.cpan.org/dist/Barcode-ZBar/
diff --git a/graphics/p5-Barcode-ZBar/pkg-plist b/graphics/p5-Barcode-ZBar/pkg-plist
new file mode 100644
index 00000000000..12e3a08945f
--- /dev/null
+++ b/graphics/p5-Barcode-ZBar/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_ARCH%%/Barcode/ZBar.pm
+%%SITE_ARCH%%/Barcode/ZBar/Image.pod
+%%SITE_ARCH%%/Barcode/ZBar/ImageScanner.pod
+%%SITE_ARCH%%/Barcode/ZBar/Processor.pod
+%%SITE_ARCH%%/Barcode/ZBar/Symbol.pod
+%%SITE_ARCH%%/auto/Barcode/ZBar/ZBar.so
+%%PERL5_MAN3%%/Barcode::ZBar.3.gz
+%%PERL5_MAN3%%/Barcode::ZBar::Image.3.gz
+%%PERL5_MAN3%%/Barcode::ZBar::ImageScanner.3.gz
+%%PERL5_MAN3%%/Barcode::ZBar::Processor.3.gz
+%%PERL5_MAN3%%/Barcode::ZBar::Symbol.3.gz