aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1999-01-22 02:06:23 +0800
committervanilla <vanilla@FreeBSD.org>1999-01-22 02:06:23 +0800
commit93157ab438b61b3a8ee1369fd7d7daf0ced249e0 (patch)
tree598f76bfa839ee4677308201d2c0e2e273532657 /graphics
parentcb68efd1b39f6ab8bab117905cec68a327eee458 (diff)
downloadfreebsd-ports-graphics-93157ab438b61b3a8ee1369fd7d7daf0ced249e0.tar.gz
freebsd-ports-graphics-93157ab438b61b3a8ee1369fd7d7daf0ced249e0.tar.zst
freebsd-ports-graphics-93157ab438b61b3a8ee1369fd7d7daf0ced249e0.zip
Upgrade to 1.0.3, (thanks god, 1.0.3 is out)
the submitter say: Attached are patches to upgrade the PNG port to 1.0.3, and to fix the two ghostscript ports which would be broken by this. PNG 1.0.3 is apparently completely backwards compatible with 1.0.2. Maintainer contacted with no response. PR: ports/9601 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/png/Makefile6
-rw-r--r--graphics/png/distinfo2
-rw-r--r--graphics/png/files/patch-aa67
-rw-r--r--graphics/png/pkg-plist1
4 files changed, 40 insertions, 36 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 24e99b305e1..906a72108da 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -3,11 +3,11 @@
# Date created: 5 Dec 1995
# Whom: ache
#
-# $Id: Makefile,v 1.15 1998/09/17 00:50:48 asami Exp $
+# $Id: Makefile,v 1.16 1998/09/17 06:30:34 tg Exp $
#
-DISTNAME= libpng-1.0.2
-PKGNAME= png-1.0.2
+DISTNAME= libpng-1.0.3
+PKGNAME= png-1.0.3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.uu.net/graphics/png/src/
diff --git a/graphics/png/distinfo b/graphics/png/distinfo
index 8b6d4d9080e..d865fc7ca99 100644
--- a/graphics/png/distinfo
+++ b/graphics/png/distinfo
@@ -1 +1 @@
-MD5 (libpng-1.0.2.tar.gz) = a8b093154f07f7b82e5c9bb77c11a0c4
+MD5 (libpng-1.0.3.tar.gz) = 06be53a1c46c4093c5c6b471cd9e4187
diff --git a/graphics/png/files/patch-aa b/graphics/png/files/patch-aa
index e4dd738597f..2a95ec30471 100644
--- a/graphics/png/files/patch-aa
+++ b/graphics/png/files/patch-aa
@@ -1,7 +1,13 @@
-*** scripts/makefile.std.orig Wed Apr 1 04:49:34 1998
---- scripts/makefile.std Fri Jul 10 03:34:22 1998
+*** scripts/makefile.std.orig Fri Jul 31 17:15:22 1998
+--- scripts/makefile.std Tue Jan 19 15:53:48 1999
***************
-*** 5,33 ****
+*** 2,19 ****
+ # Copyright (C) 1995 Guy Eric Schalnat, Group 42, Inc.
+ # For conditions of distribution and use, see copyright notice in png.h
+
+ # where make install puts libpng.a and png.h
+! prefix=/usr/local
+
# Where the zlib library and include files are located
#ZLIBLIB=/usr/local/lib
#ZLIBINC=/usr/local/include
@@ -14,24 +20,23 @@
#RANLIB=echo
RANLIB=ranlib
+--- 2,29 ----
+ # Copyright (C) 1995 Guy Eric Schalnat, Group 42, Inc.
+ # For conditions of distribution and use, see copyright notice in png.h
++ # read libpng.txt or png.h to see why PNGMAJ is 2. You should not
++ # have to change it.
++ PNGMAJ = 2
++ .if (${PORTOBJFORMAT} == "elf")
++ PNGVER = $(PNGMAJ)
++ .else
++ PNGMIN = 1
++ PNGVER = $(PNGMAJ).$(PNGMIN)
++ .endif
++
# where make install puts libpng.a and png.h
-! prefix=/usr/local
-
- OBJS = png.o pngset.o pngget.o pngrutil.o pngtrans.o pngwutil.o \
- pngread.o pngrio.o pngwio.o pngwrite.o pngrtran.o \
- pngwtran.o pngmem.o pngerror.o pngpread.o
-
-! all: libpng.a pngtest
-
- libpng.a: $(OBJS)
- ar rc $@ $(OBJS)
- $(RANLIB) $@
-
- pngtest: pngtest.o libpng.a
- $(CC) -o pngtest $(CFLAGS) pngtest.o $(LDFLAGS)
+! prefix=${PREFIX}
---- 5,55 ----
# Where the zlib library and include files are located
#ZLIBLIB=/usr/local/lib
#ZLIBINC=/usr/local/include
@@ -44,21 +49,21 @@
#RANLIB=echo
RANLIB=ranlib
+***************
+*** 22,33 ****
+ pngread.o pngrio.o pngwio.o pngwrite.o pngrtran.o \
+ pngwtran.o pngmem.o pngerror.o pngpread.o
-+ # read libpng.txt or png.h to see why PNGMAJ is 2. You should not
-+ # have to change it.
-+ PNGMAJ = 2
-+ .if (${PORTOBJFORMAT} == "elf")
-+ PNGVER = $(PNGMAJ)
-+ .else
-+ PNGMIN = 1
-+ PNGVER = $(PNGMAJ).$(PNGMIN)
-+ .endif
-+
- # where make install puts libpng.a and png.h
-! prefix=${PREFIX}
+! all: libpng.a pngtest
+
+ libpng.a: $(OBJS)
+ ar rc $@ $(OBJS)
+ $(RANLIB) $@
+
+ pngtest: pngtest.o libpng.a
+ $(CC) -o pngtest $(CFLAGS) pngtest.o $(LDFLAGS)
- OBJS = png.o pngset.o pngget.o pngrutil.o pngtrans.o pngwutil.o \
+--- 32,55 ----
pngread.o pngrio.o pngwio.o pngwrite.o pngrtran.o \
pngwtran.o pngmem.o pngerror.o pngpread.o
diff --git a/graphics/png/pkg-plist b/graphics/png/pkg-plist
index cd34e00cdbb..743400cfe33 100644
--- a/graphics/png/pkg-plist
+++ b/graphics/png/pkg-plist
@@ -1,7 +1,6 @@
include/png.h
include/pngconf.h
lib/libpng.a
-@exec ranlib %D/%F
lib/libpng.so.2.1
lib/libpng.so
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B