aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-06-07 20:11:36 +0800
committerkwm <kwm@FreeBSD.org>2011-06-07 20:11:36 +0800
commit97dcc6ecc6fc5def5770cbbf79737d9b7ef132a6 (patch)
treecb2fca125159ca44183bc067b5616d2ca04b9f7a /graphics
parentbed50c50b6445483ee0bc93f7abc8c2d06b8aff8 (diff)
downloadfreebsd-ports-graphics-97dcc6ecc6fc5def5770cbbf79737d9b7ef132a6.tar.gz
freebsd-ports-graphics-97dcc6ecc6fc5def5770cbbf79737d9b7ef132a6.tar.zst
freebsd-ports-graphics-97dcc6ecc6fc5def5770cbbf79737d9b7ef132a6.zip
Fix the genesys backend on 64 bit machines by:
Specify missing return type of function, pointers cannot be casted to int. Submitted by: hselasky@
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sane-backends/Makefile2
-rw-r--r--graphics/sane-backends/files/patch-backend__genesys.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index a9537650b77..41432d68b30 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://alioth.debian.org/frs/download.php/3258/ \
ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
diff --git a/graphics/sane-backends/files/patch-backend__genesys.c b/graphics/sane-backends/files/patch-backend__genesys.c
new file mode 100644
index 00000000000..9804688e00d
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__genesys.c
@@ -0,0 +1,11 @@
+--- backend/genesys.c.orig 2011-06-07 13:06:00.000000000 +0200
++++ backend/genesys.c 2011-06-07 13:06:46.000000000 +0200
+@@ -5436,7 +5436,7 @@
+ * @param size maximum size of the range
+ * @return a poiter to a valid range or NULL
+ */
+-static create_range(SANE_Fixed size)
++static SANE_Range *create_range(SANE_Fixed size)
+ {
+ SANE_Range *range=NULL;
+