aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-12-04 06:46:23 +0800
committerpav <pav@FreeBSD.org>2008-12-04 06:46:23 +0800
commit99ff51c2d017c6a376d477009c41e553d7a0d36f (patch)
tree0a69ca3edc4933254b581a2d38e3796018e1e783 /graphics
parentd8847ec85dd884ad100cf1c415f2a948104ed5a6 (diff)
downloadfreebsd-ports-graphics-99ff51c2d017c6a376d477009c41e553d7a0d36f.tar.gz
freebsd-ports-graphics-99ff51c2d017c6a376d477009c41e553d7a0d36f.tar.zst
freebsd-ports-graphics-99ff51c2d017c6a376d477009c41e553d7a0d36f.zip
- Update to 1.2.7
PR: ports/129128 Submitted by: Marcus von Appen <mva@sysfault.org> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_image/Makefile3
-rw-r--r--graphics/sdl_image/distinfo6
-rw-r--r--graphics/sdl_image/files/patch-IMG_gif.c13
-rw-r--r--graphics/sdl_image/files/patch-IMG_lbm.c28
4 files changed, 4 insertions, 46 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 0613121c311..a758e94b1e7 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdl_image
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.2.7
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
diff --git a/graphics/sdl_image/distinfo b/graphics/sdl_image/distinfo
index 7b4f9beb038..6d497da6b9b 100644
--- a/graphics/sdl_image/distinfo
+++ b/graphics/sdl_image/distinfo
@@ -1,3 +1,3 @@
-MD5 (SDL_image-1.2.6.tar.gz) = b866dc4f647517bdaf57f6ffdefd013e
-SHA256 (SDL_image-1.2.6.tar.gz) = 88fcb1dbf934af33163667a6677312065c7d0a7f01cd764e3374c4c19b386ec4
-SIZE (SDL_image-1.2.6.tar.gz) = 1308812
+MD5 (SDL_image-1.2.7.tar.gz) = a729ff61f74f0a45ec7fe36354cf938e
+SHA256 (SDL_image-1.2.7.tar.gz) = 14e4d9932ae2af03d814cca9e56ab9ba0091ffe06c9387dde74dfb03a4dde3b3
+SIZE (SDL_image-1.2.7.tar.gz) = 1315517
diff --git a/graphics/sdl_image/files/patch-IMG_gif.c b/graphics/sdl_image/files/patch-IMG_gif.c
deleted file mode 100644
index 23e970bd147..00000000000
--- a/graphics/sdl_image/files/patch-IMG_gif.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- IMG_gif.c 2007/02/13 10:09:17 2970
-+++ IMG_gif.c 2007/12/28 16:43:56 3462
-@@ -418,6 +418,10 @@
- static int stack[(1 << (MAX_LWZ_BITS)) * 2], *sp;
- register int i;
-
-+ /* Fixed buffer overflow found by Michael Skladnikiewicz */
-+ if (input_code_size > MAX_LWZ_BITS)
-+ return -1;
-+
- if (flag) {
- set_code_size = input_code_size;
- code_size = set_code_size + 1;
diff --git a/graphics/sdl_image/files/patch-IMG_lbm.c b/graphics/sdl_image/files/patch-IMG_lbm.c
deleted file mode 100644
index 5f67e6ded16..00000000000
--- a/graphics/sdl_image/files/patch-IMG_lbm.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- IMG_lbm.c 2007/07/20 04:37:11 3341
-+++ IMG_lbm.c 2008/01/03 20:05:34 3521
-@@ -28,6 +28,7 @@
- EHB and HAM (specific Amiga graphic chip modes) support added by Marc Le Douarain
- (http://www.multimania.com/mavati) in December 2003.
- Stencil and colorkey fixes by David Raulo (david.raulo AT free DOT fr) in February 2004.
-+ Buffer overflow fix in RLE decompression by David Raulo in January 2008.
- */
-
- #include <stdio.h>
-@@ -328,7 +329,7 @@
- count ^= 0xFF;
- count += 2; /* now it */
-
-- if ( !SDL_RWread( src, &color, 1, 1 ) )
-+ if ( ( count > remainingbytes ) || !SDL_RWread( src, &color, 1, 1 ) )
- {
- error="error reading BODY chunk";
- goto done;
-@@ -339,7 +340,7 @@
- {
- ++count;
-
-- if ( !SDL_RWread( src, ptr, count, 1 ) )
-+ if ( ( count > remainingbytes ) || !SDL_RWread( src, ptr, count, 1 ) )
- {
- error="error reading BODY chunk";
- goto done;