aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-08-09 03:19:35 +0800
committerbsam <bsam@FreeBSD.org>2006-08-09 03:19:35 +0800
commita7d300e16131e12fc449521e7ef24e8546f1b7a1 (patch)
treeac18735c003b65cc0f7960d0a4071ebc17cd8e4e /graphics
parentec23bc71882958bf6c534d66e0f8de76b65da2da (diff)
downloadfreebsd-ports-graphics-a7d300e16131e12fc449521e7ef24e8546f1b7a1.tar.gz
freebsd-ports-graphics-a7d300e16131e12fc449521e7ef24e8546f1b7a1.tar.zst
freebsd-ports-graphics-a7d300e16131e12fc449521e7ef24e8546f1b7a1.zip
Let the ports which have both bz2 and gz distfiles extract on 4.x
(actually, if ${OSVERSION} < 502111): - remove BROKEN from graphics/linux_dri-devel; - remove IGNORE from graphics/linux_dri. The next technique is used (thanks Brooks Davis): .if ${OSVERSION} < 502111 EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive TAR= bsdtar .endif Approved by: netchild (mentor, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux_dri-devel/Makefile11
-rw-r--r--graphics/linux_dri/Makefile5
2 files changed, 10 insertions, 6 deletions
diff --git a/graphics/linux_dri-devel/Makefile b/graphics/linux_dri-devel/Makefile
index dce73833984..25d94b2d60f 100644
--- a/graphics/linux_dri-devel/Makefile
+++ b/graphics/linux_dri-devel/Makefile
@@ -33,6 +33,13 @@ MODULELIST= i810_dri.so i915_dri.so mach64_dri.so mga_dri.so r128_dri.so \
sis_dri.so tdfx_dri.so
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502111
+EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
+TAR= bsdtar
+.endif
+
do-install:
${MKDIR} ${PREFIX}/usr/X11R6/lib/modules/dri
${INSTALL_PROGRAM} ${WRKSRC}/linux_dri/libGL.so.1.2 \
@@ -61,8 +68,4 @@ do-install:
post-install:
@${LDCONFIG_LINUX} ${PREFIX}/usr/X11R6/lib
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not extract on 4.x (both bz2 and gz sources are used)
-.endif
.include <bsd.port.post.mk>
diff --git a/graphics/linux_dri/Makefile b/graphics/linux_dri/Makefile
index a6c8e68932d..45f69cf51f3 100644
--- a/graphics/linux_dri/Makefile
+++ b/graphics/linux_dri/Makefile
@@ -35,8 +35,9 @@ LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not extract with the tar in FreeBSD 4.x
+.if ${OSVERSION} < 502111
+EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
+TAR= bsdtar
.endif
do-install: