aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-02 11:49:20 +0800
committerpav <pav@FreeBSD.org>2004-04-02 11:49:20 +0800
commitaaa8cc7ba393649e8dbc06ce0837c2766051f06a (patch)
tree0c0e29bdcf0d9c58b7b8cab9fb8030251c957f94 /graphics
parent02788076d8390940e5f068f4b77990d8ca105b0b (diff)
downloadfreebsd-ports-graphics-aaa8cc7ba393649e8dbc06ce0837c2766051f06a.tar.gz
freebsd-ports-graphics-aaa8cc7ba393649e8dbc06ce0837c2766051f06a.tar.zst
freebsd-ports-graphics-aaa8cc7ba393649e8dbc06ce0837c2766051f06a.zip
- Revert my previous commit, it was completely bogus [1]
- Respect CFLAGS [2] Requested by: maintainer [1] Submitted by: maintainer [2]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glew/Makefile6
-rw-r--r--graphics/glew/files/patch-Makefile3
2 files changed, 1 insertions, 8 deletions
diff --git a/graphics/glew/Makefile b/graphics/glew/Makefile
index 1514bbbf9bc..cb1222028fa 100644
--- a/graphics/glew/Makefile
+++ b/graphics/glew/Makefile
@@ -19,13 +19,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GL= yes
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= CC="${CC}"
-
-post-patch:
- ${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' \
- ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/glewinfo ${PREFIX}/bin
diff --git a/graphics/glew/files/patch-Makefile b/graphics/glew/files/patch-Makefile
index 4a5652e240e..da5238fb7e3 100644
--- a/graphics/glew/files/patch-Makefile
+++ b/graphics/glew/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Sun Dec 14 18:21:44 2003
+++ Makefile Sun Jan 25 07:38:41 2004
-@@ -83,6 +83,27 @@
+@@ -83,6 +83,26 @@
else
# ----------------------------------------------------------------------------
@@ -16,7 +16,6 @@
+LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
+GLEW_DEST = ${X11BASE}
+WARN = -Wall -W
-+POPT = -O2
+BIN.SUFFIX =
+LIB.SONAME = lib$(NAME).so.$(GLEW_MAJOR)
+LIB.DEVLNK = lib$(NAME).so