aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-03-02 11:11:39 +0800
committerijliao <ijliao@FreeBSD.org>2004-03-02 11:11:39 +0800
commitadbca25b2bc5a9117e0f6726023756d26efb9b9f (patch)
tree5e4ae5cdc9fbda34d549f302ff4ae3b157a06898 /graphics
parentce054aaedbff96e9903f1c7c4efcfadd4aad656a (diff)
downloadfreebsd-ports-graphics-adbca25b2bc5a9117e0f6726023756d26efb9b9f.tar.gz
freebsd-ports-graphics-adbca25b2bc5a9117e0f6726023756d26efb9b9f.tar.zst
freebsd-ports-graphics-adbca25b2bc5a9117e0f6726023756d26efb9b9f.zip
add batik 1.5.1
SVG Toolkit
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/batik/Makefile44
-rw-r--r--graphics/batik/distinfo2
-rw-r--r--graphics/batik/pkg-descr5
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4cf117a1d1a..58fb5b31506 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -22,6 +22,7 @@
SUBDIR += ayam
SUBDIR += backfract
SUBDIR += barcode
+ SUBDIR += batik
SUBDIR += bbrb
SUBDIR += blender
SUBDIR += blender-devel
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
new file mode 100644
index 00000000000..e855a1b30aa
--- /dev/null
+++ b/graphics/batik/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: batik
+# Date created: Feb 25, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= batik
+PORTVERSION= 1.5.1
+CATEGORIES= graphics java
+MASTER_SITES= ${MASTER_SITE_APACHE_XML}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SVG Toolkit
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+
+USE_ZIP= yes
+USE_JAVA= 1.3+
+NEED_JAVAC= yes
+WRKSRC= ${WRKDIR}/xml-${PORTNAME}
+ANT?= /usr/local/bin/ant
+ANT_ALL_TARGET= jars
+BATIK_HOME= ${PREFIX}/batik
+
+.if !defined(NOPORTDOCS)
+ANT_ALL_TARGET+= html
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_ALL_TARGET}
+
+do-install:
+ @${MKDIR} ${BATIK_HOME}
+ @${CP} -R ${WRKSRC}/${PORTNAME}-${PORTVERSION} ${BATIK_HOME}
+ @${FIND} ${BATIK_HOME} -type f | \
+ ${SED} -e "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${BATIK_HOME} -type d | ${SORT} -r | \
+ ${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/graphics/batik/distinfo b/graphics/batik/distinfo
new file mode 100644
index 00000000000..eab3beffdcc
--- /dev/null
+++ b/graphics/batik/distinfo
@@ -0,0 +1,2 @@
+MD5 (batik-src-1.5.1.zip) = 8a3ba8b76dcef9415216d6a5b9685a9c
+SIZE (batik-src-1.5.1.zip) = 11474737
diff --git a/graphics/batik/pkg-descr b/graphics/batik/pkg-descr
new file mode 100644
index 00000000000..f1506a92302
--- /dev/null
+++ b/graphics/batik/pkg-descr
@@ -0,0 +1,5 @@
+Batik is a Java(tm) technology based toolkit for applications or applets that
+want to use images in the Scalable Vector Graphics (SVG) format for various
+purposes, such as viewing, generation or manipulation.
+
+WWW: http://xml.apache.org/batik/