aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-09-24 04:50:58 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-09-24 04:50:58 +0800
commitc36b010b1f056e8431986a146f9f24249ec87dba (patch)
tree81b11627023758a643e35cf046e91c0acf635c80 /graphics
parent6310eadcbdacc3282f8fc48002309760624dd886 (diff)
downloadfreebsd-ports-graphics-c36b010b1f056e8431986a146f9f24249ec87dba.tar.gz
freebsd-ports-graphics-c36b010b1f056e8431986a146f9f24249ec87dba.tar.zst
freebsd-ports-graphics-c36b010b1f056e8431986a146f9f24249ec87dba.zip
- Add USE_LDCONFIG
- Minor portlint fixes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile11
-rw-r--r--graphics/osg/Makefile11
2 files changed, 12 insertions, 10 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 4807480703b..63e766b8d37 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= osg
PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-2.6/
DISTNAME= OpenSceneGraph-${PORTVERSION}
@@ -15,14 +15,15 @@ DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ OpenGL scene graph library for real-time rendering
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
WANT_SDL= yes
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+USE_LDCONFIG= yes
OPTIONS= CURL "Support for cURL" off \
FREETYPE "Support for FreeType" on \
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 4807480703b..63e766b8d37 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= osg
PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-2.6/
DISTNAME= OpenSceneGraph-${PORTVERSION}
@@ -15,14 +15,15 @@ DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ OpenGL scene graph library for real-time rendering
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
WANT_SDL= yes
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+USE_LDCONFIG= yes
OPTIONS= CURL "Support for cURL" off \
FREETYPE "Support for FreeType" on \