aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-26 17:28:49 +0800
committerkris <kris@FreeBSD.org>2004-02-26 17:28:49 +0800
commitca6b30a2a8b13ec8f66609ff809d50e4b878c1e4 (patch)
treee2aa2eaddd1fd6236b95a6123cd11904077b6937 /graphics
parent8fba366dd06c2fd4e574a3d156bac63642d2ea72 (diff)
downloadfreebsd-ports-graphics-ca6b30a2a8b13ec8f66609ff809d50e4b878c1e4.tar.gz
freebsd-ports-graphics-ca6b30a2a8b13ec8f66609ff809d50e4b878c1e4.tar.zst
freebsd-ports-graphics-ca6b30a2a8b13ec8f66609ff809d50e4b878c1e4.zip
BROKEN on alpha: Does not compile
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gtkdps/Makefile8
-rw-r--r--graphics/qiv/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/gtkdps/Makefile b/graphics/gtkdps/Makefile
index 036e2aa953d..c49fd1f4d48 100644
--- a/graphics/gtkdps/Makefile
+++ b/graphics/gtkdps/Makefile
@@ -24,4 +24,10 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-dps-includes=${X11BASE}/include \
--with-dps-libraries=${X11BASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/qiv/Makefile b/graphics/qiv/Makefile
index 3b95e51d90d..feec381aee3 100644
--- a/graphics/qiv/Makefile
+++ b/graphics/qiv/Makefile
@@ -24,6 +24,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= qiv.1
PLIST_FILES= bin/qiv
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
do-configure:
@ ${MV} ${WRKSRC}/qiv.1 ${WRKSRC}/qiv.1.pre_sed
@ ${SED} -e 's#\/usr\/bin#${PREFIX}/bin#g' \
@@ -39,4 +45,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qiv ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/qiv.1 ${PREFIX}/man/man1/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>