aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2010-12-25 09:45:34 +0800
committermaho <maho@FreeBSD.org>2010-12-25 09:45:34 +0800
commitd0e038b388c655bb51b8a933b47698f0a02efcb4 (patch)
treedff3de0220ff24623e9f91ed4816aa7b6ef126fc /graphics
parent6a9c1e9203830d829b131014c0a175647fcf1b93 (diff)
downloadfreebsd-ports-graphics-d0e038b388c655bb51b8a933b47698f0a02efcb4.tar.gz
freebsd-ports-graphics-d0e038b388c655bb51b8a933b47698f0a02efcb4.tar.zst
freebsd-ports-graphics-d0e038b388c655bb51b8a933b47698f0a02efcb4.zip
Build fix.
PR: 152539 Submitted by: Andrey Zholos <aaz@althenia.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/megapov/Makefile2
-rw-r--r--graphics/megapov/files/patch-png_pov.cpp20
2 files changed, 22 insertions, 0 deletions
diff --git a/graphics/megapov/Makefile b/graphics/megapov/Makefile
index da9be6bf8f0..b265ccc5df5 100644
--- a/graphics/megapov/Makefile
+++ b/graphics/megapov/Makefile
@@ -29,6 +29,8 @@ CONFIGURE_ARGS+= COMPILED_BY="ports@FreeBSD.org"
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.pre.mk>
diff --git a/graphics/megapov/files/patch-png_pov.cpp b/graphics/megapov/files/patch-png_pov.cpp
new file mode 100644
index 00000000000..11ea26f73c3
--- /dev/null
+++ b/graphics/megapov/files/patch-png_pov.cpp
@@ -0,0 +1,20 @@
+--- source/png_pov.cpp.orig 2005-08-23 20:20:33.000000000 +0100
++++ source/png_pov.cpp 2010-11-24 10:15:11.000000000 +0000
+@@ -1437,7 +1437,7 @@
+ if(r_info_ptr->valid & PNG_INFO_tRNS)
+ {
+ for (index = 0; index < r_info_ptr->num_trans; index++)
+- cmap[index].Transmit = 255 - r_info_ptr->trans[index];
++ cmap[index].Transmit = 255 - r_info_ptr->trans_alpha[index];
+ }
+
+ Image->data.map_lines = (unsigned char **)POV_MALLOC(height * sizeof(unsigned char *), "PNG image");
+@@ -1470,7 +1470,7 @@
+ if(r_info_ptr->valid & PNG_INFO_tRNS)
+ {
+ for (index = 0; index < r_info_ptr->num_trans; index++)
+- cmap[index].Transmit = 255 - r_info_ptr->trans[index];
++ cmap[index].Transmit = 255 - r_info_ptr->trans_alpha[index];
+ }
+
+ Image->data.map_lines = (unsigned char **)POV_MALLOC(height * sizeof(unsigned char *), "PNG image");