aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-05-13 11:49:08 +0800
committerdanfe <danfe@FreeBSD.org>2011-05-13 11:49:08 +0800
commite42055ae461340c26b23ae468fe458da40d627be (patch)
tree1b9da2d8747442619bb26d813b32dd4aff735d47 /graphics
parent152876a419b290dd8ee8237c74d4bc48339b6ac9 (diff)
downloadfreebsd-ports-graphics-e42055ae461340c26b23ae468fe458da40d627be.tar.gz
freebsd-ports-graphics-e42055ae461340c26b23ae468fe458da40d627be.tar.zst
freebsd-ports-graphics-e42055ae461340c26b23ae468fe458da40d627be.zip
Update to newer snapshot version (20061110) which fixes a PBM crash problem.
There is no known official martersite for now, but distfile can be fetched from Debian mirrors, so switch to them for a time being. PR: ports/156272 Submitted by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xli/Makefile11
-rw-r--r--graphics/xli/distinfo4
-rw-r--r--graphics/xli/files/patch-xli.c10
3 files changed, 19 insertions, 6 deletions
diff --git a/graphics/xli/Makefile b/graphics/xli/Makefile
index 9189e0ecccd..2f8de957dae 100644
--- a/graphics/xli/Makefile
+++ b/graphics/xli/Makefile
@@ -7,11 +7,11 @@
PORTNAME= xli
PORTVERSION= 1.17.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics
-#MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-#MASTER_SITE_SUBDIR= applications
-DISTNAME= xli-2005-09-04
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/x/${PORTNAME}
+DISTNAME= xli_${PORTVERSION}+${XLI_SNAPVER:C/-//g}.orig
MAINTAINER= lichray@gmail.com
COMMENT= Utilities to display images in X11
@@ -21,9 +21,12 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
USE_XORG= xi
USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/xli-${XLI_SNAPVER}
MAN1= xli.1 xlito.1
MLINKS= xli.1 xview.1 xli.1 xsetbg.1
PLIST_FILES= bin/xli bin/xlito bin/xview bin/xsetbg lib/X11/app-defaults/Xli
+XLI_SNAPVER= 2006-11-10
+
.include <bsd.port.mk>
diff --git a/graphics/xli/distinfo b/graphics/xli/distinfo
index b74d5e178f4..fb62059fe75 100644
--- a/graphics/xli/distinfo
+++ b/graphics/xli/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xli-2005-09-04.tar.gz) = 9f513165fb3bf3fdde813db82c8f529fff66290814ce602c9715f6f52e9309f0
-SIZE (xli-2005-09-04.tar.gz) = 201219
+SHA256 (xli_1.17.0+20061110.orig.tar.gz) = 7b6e28f64012a56e848be4f57263b87a30014418ba4ecda556d8a0bde3c498fb
+SIZE (xli_1.17.0+20061110.orig.tar.gz) = 201326
diff --git a/graphics/xli/files/patch-xli.c b/graphics/xli/files/patch-xli.c
new file mode 100644
index 00000000000..7a7d4ff2950
--- /dev/null
+++ b/graphics/xli/files/patch-xli.c
@@ -0,0 +1,10 @@
+--- xli.c.orig 2006-11-10 23:52:14.000000000 -0600
++++ xli.c 2011-04-08 04:57:58.469540144 -0500
+@@ -364,6 +364,7 @@ int main(int argc, char *argv[])
+ idisp = itmp;
+ }
+ freeImage(inew);
++ inew = idisp;
+ }
+
+ /*