aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-03 08:28:51 +0800
committeredwin <edwin@FreeBSD.org>2003-04-03 08:28:51 +0800
commitf22fcf9a50ac6d60156d72d6cc23ddc009a3e855 (patch)
tree03530ee0c65dd44cea08d5087cf5af6971ee6a7a /graphics
parent9f2023fa51669b0cd1582aef6d637447ab25195c (diff)
downloadfreebsd-ports-graphics-f22fcf9a50ac6d60156d72d6cc23ddc009a3e855.tar.gz
freebsd-ports-graphics-f22fcf9a50ac6d60156d72d6cc23ddc009a3e855.tar.zst
freebsd-ports-graphics-f22fcf9a50ac6d60156d72d6cc23ddc009a3e855.zip
New Port graphics/p5-GD2
This port was based directly on p5-GD PR: ports/49097 Submitted by: Philip M. Gollucci <philip@p6m7g8.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-GD2/Makefile19
-rw-r--r--graphics/p5-GD2/distinfo2
-rw-r--r--graphics/p5-GD2/files/patch-aa84
-rw-r--r--graphics/p5-GD2/pkg-plist3
4 files changed, 70 insertions, 38 deletions
diff --git a/graphics/p5-GD2/Makefile b/graphics/p5-GD2/Makefile
index 248621afd43..19e6e983d64 100644
--- a/graphics/p5-GD2/Makefile
+++ b/graphics/p5-GD2/Makefile
@@ -1,25 +1,26 @@
-# New ports collection makefile for: p5-GD
-# Date created: June 26th 1997
-# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+# New ports collection makefile for: p5-GD2
+# Date created: March 11, 2003
+# Whom: Philip M. Gollucci <philip@p6m7g8.com>
#
# $FreeBSD$
#
-PORTNAME= GD
-PORTVERSION= 1.41
+PORTNAME= GD2
+PORTVERSION= 2.06
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= GD
PKGNAMEPREFIX= p5-
+DISTNAME= GD-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A perl5 interface to Gd Graphics Library
+MAINTAINER= philip@p6m7g8.com
+COMMENT= A perl5 interface to Gd Graphics Library version2
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd2
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= GD.3
+MAN3= GD.3 GD::Polyline.3
.include <bsd.port.mk>
diff --git a/graphics/p5-GD2/distinfo b/graphics/p5-GD2/distinfo
index 04586f6731a..6420c11a931 100644
--- a/graphics/p5-GD2/distinfo
+++ b/graphics/p5-GD2/distinfo
@@ -1 +1 @@
-MD5 (GD-1.41.tar.gz) = 9f11b3f6bb73f04d2bc3f02df0662bdd
+MD5 (GD-2.06.tar.gz) = 90025c06e22c91e22588cee1567d3c7c
diff --git a/graphics/p5-GD2/files/patch-aa b/graphics/p5-GD2/files/patch-aa
index 4f58f84665b..171d206d9af 100644
--- a/graphics/p5-GD2/files/patch-aa
+++ b/graphics/p5-GD2/files/patch-aa
@@ -1,49 +1,79 @@
---- Makefile.PL.orig Wed Jun 19 14:02:59 2002
-+++ Makefile.PL Sat Jun 22 21:25:18 2002
-@@ -3,40 +3,17 @@
- warn "NOTICE: This module requires libgd 1.8.4 or higher (shared library version 4.X).\n";
+--- Makefile.PL.orig Wed Nov 27 16:29:57 2002
++++ Makefile.PL Tue Mar 11 01:17:10 2003
+@@ -6,46 +6,23 @@
+
# =====> PATHS: CHECK AND ADJUST <=====
--my @INC = qw(-I/usr/local/include -I/usr/local/include/gd);
--my @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/local/lib );
+-my @INC = qw(-I/usr/local/include -I/usr/local/include/gd);
+-my @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/local/lib);
-my @LIBS = qw(-lgd -lpng -lz);
-
+-if ($^O eq 'VMS'){
+- warn "This is a build on OpenVMS. In case of problems with the build\n";
+- warn "do not bother Lincoln Stein but get in touch with\n";
+- warn "Martin P.J. Zinser (zinser\@decus.de)\n\n";
+-
+- if ($ENV{"LIB_ROOT"} eq "") {
+- warn "Define lib_root as a concealed logical pointing to the\n";
+- warn "Top directory where you have your libraries installed\n";
+- warn "E.g. define/job/trans=conc lib_root public$device:[public.util.libs.]\n";
+- warn "Also define the logical pubbin to point to the location\n";
+- warn "of the object libraries\n";
+- warn "Then re-invoke Makefile.PL\n";
+- warn "Exiting now...\n";
+- exit;
+- }
+-
+- @INC = qw(-I/lib_root/gd -I/lib_root/libpng -I/lib_root/zlib);
+- @LIBPATH = qw(-Lpubbin);
+- @LIBS = qw(-llibgd.olb -llibpng.olb -llibz.olb);
+-}
++my @INC = qw(-I$ENV{LOCALBASE}/include -I$ENV{LOCALBASE}/include/freetype2 -I$ENV{X11BASE}/include -I$ENV{X11BASE}/include/X11);
++my @LIBPATH = qw(-L$ENV{LOCALBASE}/lib -L$ENV{X11BASE}/lib);
++my @LIBS = qw(-lfreetype -ljpeg -lgd -lpng -lz);
+
+ # path to libgd
+ warn "\n";
+-my $PREFIX = lc prompt('Where is libgd installed?','/usr/lib');
++my $PREFIX = "$ENV{LOCALBASE}/lib";
++
+ unless ($PREFIX eq '/usr/lib') {
+ $PREFIX =~ s!/lib$!!;
+ unshift @INC,"-I$PREFIX/include";
+ unshift @LIBPATH,"-L$PREFIX/lib";
+ }
+
-# FEATURE FLAGS
-warn "\nPlease choose the features that match how libgd was built:\n";
-
-my $JPEG = lc prompt('Build JPEG support?','y') eq 'y';
--my $TTF = lc prompt('Build FreeType support?','y') eq 'y';
+-my $FT = lc prompt('Build FreeType support?','y') eq 'y';
-my $XPM = $^O !~ /^freebsd|MSWin32$/ && lc prompt('Build XPM support?','y') eq 'y';
--my $GIF = lc prompt('Build GIF support (for patched versions of gd)?','n') eq 'y';
-+my @INC = qw(-I/usr/local/include -I/usr/local/include/gd -I/usr/local/include/freetype -I/usr/X11R6/include -I/usr/X11R6/include/X11);
-+my @LIBPATH = qw(-L/usr/local/lib -L/usr/X11R6/lib);
-+my @LIBS = qw(-lfreetype -ljpeg -lgd -lpng -lz);
++$JPEG=1;
++$FT=1;
++$XPM=1;
my $FCGI = 0; # set to 1 to build compatability with fastCGI
--warn "\nIf you experience compile problems, please check the \@INC, \@LIBPATH and \@LIBS\n",
-- "arrays defined in Makefile.PL and manually adjust, if necessary.\n\n";
--
--#### no user-serviceable parts below #####
--
--push @LIBS,'-lfreetype' if $TTF;
--push @LIBS,'-ljpeg' if $JPEG;
--push @LIBS, '-lm' unless $^O eq 'MSWin32';
--
+@@ -61,16 +38,13 @@
+ push @INC, '-I/lib_root/ft2/include/freetype' if ($FT && $^O eq 'VMS');
+ push @INC, '-I/X11' if ($XPM && $^O eq 'VMS');
+
-# FreeBSD 3.3 with libgd built from ports croaks if -lXpm is specified
-if ($^O ne 'freebsd' && $^O ne 'MSWin32') {
-- push @LIBS,'-lX11','-lXpm' if $XPM;
--}
-+push @LIBS,'-lX11','-lXpm' unless $^O eq 'MSWin32';
++if ($^O ne 'MSWin32') {
+ push @LIBS,'-lX11','-lXpm' if $XPM;
+ }
my $CAPI = defined $ExtUtils::MakeMaker::CAPI_support ? 'TRUE' : 'FALSE';
-my $DEFINES = '';
-$DEFINES .= ' -DHAVE_JPEG' if $JPEG;
--$DEFINES .= ' -DHAVE_TTF' if $TTF;
+-$DEFINES .= ' -DHAVE_FT' if $FT;
-$DEFINES .= ' -DHAVE_XPM' if $XPM;
--$DEFINES .= ' -DHAVE_GIF' if $GIF;
-+my $DEFINES = '-DHAVE_JPEG -DHAVE_TTF';
-+$DEFINES .= ' -DHAVE_XPM' unless $^O eq 'MSWin32';
+++my $DEFINES = '-DHAVE_JPEG -DHAVE_TTF';
+++$DEFINES .= ' -DHAVE_XPM' unless $^O eq 'MSWin32';
$DEFINES .= ' -DFCGI' if $FCGI;
WriteMakefile(
+
+
diff --git a/graphics/p5-GD2/pkg-plist b/graphics/p5-GD2/pkg-plist
index d87ad5c5760..383f18c368f 100644
--- a/graphics/p5-GD2/pkg-plist
+++ b/graphics/p5-GD2/pkg-plist
@@ -1,8 +1,9 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/patch_gd.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD/Polyline.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/qd.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/GD.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/GD.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/autosplit.ix
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD