aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-06-01 22:16:13 +0800
committerdanfe <danfe@FreeBSD.org>2016-06-01 22:16:13 +0800
commitf5161f74ce86a803284ed187b1026d57f31e0dda (patch)
treeacd01659c31e63436053dec40e5cee244e11fe6e /graphics
parent7819ab107c1fb39abe1a740315747bf53755f970 (diff)
downloadfreebsd-ports-graphics-f5161f74ce86a803284ed187b1026d57f31e0dda.tar.gz
freebsd-ports-graphics-f5161f74ce86a803284ed187b1026d57f31e0dda.tar.zst
freebsd-ports-graphics-f5161f74ce86a803284ed187b1026d57f31e0dda.zip
Fix installed header by replacing vendor-specific (mainly MSVC) keyword
`__forceinline' with `inline __attribute__((always_inline))', which is how upstream originally defines it in order to be understood by both Clang and GCC, and don't force CHOSEN_COMPILER_TYPE as it is not needed anymore. Bump port revision.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/embree/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/embree/Makefile b/graphics/embree/Makefile
index 1b99c6324db..6409366d357 100644
--- a/graphics/embree/Makefile
+++ b/graphics/embree/Makefile
@@ -4,6 +4,7 @@
PORTNAME= embree
DISTVERSIONPREFIX= v
DISTVERSION= 2.10.0
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= danfe@FreeBSD.org
@@ -24,8 +25,7 @@ USE_XORG= xmu
USE_LDCONFIG= yes
CMAKE_ARGS= -DRTCORE_TASKING_SYSTEM:STRING=INTERNAL \
- -DENABLE_ISPC_SUPPORT:BOOL=OFF \
- -DCOMPILER:STRING=${CHOSEN_COMPILER_TYPE:tu}
+ -DENABLE_ISPC_SUPPORT:BOOL=OFF
CXXFLAGS+= -msse2 # required on i386
@@ -57,5 +57,7 @@ post-patch:
@${REINPLACE_CMD} -e '/encodeRGB8_to_JPEG/s,size_t \*,unsigned \
long *,' ${WRKSRC}/tutorials/common/image/image.h \
${WRKSRC}/tutorials/common/image/jpeg.cpp
+ @${REINPLACE_CMD} -e 's,__forceinline,inline __attribute__((always_inline)),' \
+ ${WRKSRC}/include/embree2/rtcore_ray.h
.include <bsd.port.mk>