aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-10 02:01:25 +0800
committerpav <pav@FreeBSD.org>2006-04-10 02:01:25 +0800
commitfd89deb05eae0be33c2dd2fd9082e8399a13132c (patch)
tree66d78010684648b135a8e920d971b9f7c5568f3d /graphics
parentc196e4a751e04e7fb193941f9e220ed4067828eb (diff)
downloadfreebsd-ports-graphics-fd89deb05eae0be33c2dd2fd9082e8399a13132c.tar.gz
freebsd-ports-graphics-fd89deb05eae0be33c2dd2fd9082e8399a13132c.tar.zst
freebsd-ports-graphics-fd89deb05eae0be33c2dd2fd9082e8399a13132c.zip
GLText is a portable font rendering library for C++ OpenGL applications. It
uses FreeType2 to read and render high-quality TrueType fonts with a minimal footprint. With just a few easy lines of C++, you can add gorgeously rendered text to your graphical applications. GLText is an open source project licensed under the LGPL. Basically this means that you can use and link your application with it regardless of what license your application uses. If you make changes to GLText, however, you must make those changes open source under the LGPL. Written with portablility in mind, GLText works on Windows, Linux, FreeBSD and IRIX - virtually anywhere that FreeType2 supports. WWW: http://gltext.sourceforge.net PR: ports/93617 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libgltext/Makefile70
-rw-r--r--graphics/libgltext/distinfo3
-rw-r--r--graphics/libgltext/pkg-descr14
-rw-r--r--graphics/libgltext/pkg-plist20
5 files changed, 108 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9e8e117a766..d6b995d2406 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -308,6 +308,7 @@
SUBDIR += libggigcp
SUBDIR += libggimisc
SUBDIR += libggiwmh
+ SUBDIR += libgltext
SUBDIR += libglut
SUBDIR += libgnomecanvas
SUBDIR += libgnomecanvasmm
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
new file mode 100644
index 00000000000..cd559dd6fe7
--- /dev/null
+++ b/graphics/libgltext/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: libgltext
+# Date created: 2006-02-20
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgltext
+PORTVERSION= 0.3.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gltext
+DISTNAME= gltext-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Portable font rendering library for C++
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_X_PREFIX= yes
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+
+OPTIONS= EXAMPLES "Compile examples, need libglut" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXAMPLES)
+LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+FLAG_EXAMPLES= true
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PORTNAME}-${PORTVERSION}.so \
+ ${PREFIX}/lib/${PORTNAME}.so.0
+ ${INSTALL_DATA} ${WRKSRC}/src/.libs/${PORTNAME}.a \
+ ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.la \
+ ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/src/gltext.h ${PREFIX}/include
+
+ @cd ${PREFIX}/lib && \
+ ${LN} -s ${PORTNAME}.so.0 ${PORTNAME}.so
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/tutorial.txt ${DOCSDIR}
+.endif
+
+.if defined(FLAG_EXAMPLES)
+.for DIRE in alpha fps simple sizes
+ @${MKDIR} ${EXAMPLESDIR}/${DIRE}
+ @cd ${WRKSRC}/examples && \
+ ${INSTALL_DATA} ${DIRE}/${DIRE} ${DIRE}/${DIRE}.cpp ${EXAMPLESDIR}/${DIRE}
+.endfor
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Examples source and binary on ${EXAMPLESDIR}"
+ @${ECHO_MSG} ""
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libgltext/distinfo b/graphics/libgltext/distinfo
new file mode 100644
index 00000000000..bd51d94c1ed
--- /dev/null
+++ b/graphics/libgltext/distinfo
@@ -0,0 +1,3 @@
+MD5 (gltext-0.3.1.tar.gz) = 561da5749a117a78a107291f7cb3ebd0
+SHA256 (gltext-0.3.1.tar.gz) = 44bcbf2ac0d9fa011b6ef703efb085bc2f21724d565a8ec6c334159304031bed
+SIZE (gltext-0.3.1.tar.gz) = 364843
diff --git a/graphics/libgltext/pkg-descr b/graphics/libgltext/pkg-descr
new file mode 100644
index 00000000000..e75ed331552
--- /dev/null
+++ b/graphics/libgltext/pkg-descr
@@ -0,0 +1,14 @@
+GLText is a portable font rendering library for C++ OpenGL applications. It
+uses FreeType2 to read and render high-quality TrueType fonts with a minimal
+footprint. With just a few easy lines of C++, you can add gorgeously
+rendered text to your graphical applications.
+
+GLText is an open source project licensed under the LGPL. Basically this means
+that you can use and link your application with it regardless of what license
+your application uses. If you make changes to GLText, however,
+you must make those changes open source under the LGPL.
+
+Written with portablility in mind, GLText works on Windows, Linux, FreeBSD and
+IRIX - virtually anywhere that FreeType2 supports.
+
+WWW: http://gltext.sourceforge.net
diff --git a/graphics/libgltext/pkg-plist b/graphics/libgltext/pkg-plist
new file mode 100644
index 00000000000..eb11866ce43
--- /dev/null
+++ b/graphics/libgltext/pkg-plist
@@ -0,0 +1,20 @@
+include/gltext.h
+lib/libgltext.so.0
+lib/libgltext.so
+lib/libgltext.la
+lib/libgltext.a
+%%PORTDOCS%%%%DOCSDIR%%/tutorial.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/alpha/alpha
+%%EXAMPLES%%%%EXAMPLESDIR%%/alpha/alpha.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/fps/fps
+%%EXAMPLES%%%%EXAMPLESDIR%%/fps/fps.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/simple/simple
+%%EXAMPLES%%%%EXAMPLESDIR%%/simple/simple.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/sizes/sizes
+%%EXAMPLES%%%%EXAMPLESDIR%%/sizes/sizes.cpp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/alpha
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/fps
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/simple
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/sizes
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%