aboutsummaryrefslogtreecommitdiffstats
path: root/irc/erc/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-26 05:59:21 +0800
committerpav <pav@FreeBSD.org>2004-05-26 05:59:21 +0800
commitc5aec8674975b00cf2acc722975eac94ca5be878 (patch)
tree608492c76d11d26035aeb196906bb4a9ba0998f1 /irc/erc/Makefile
parent9f5665b236ec9fa6a4702857e553c4c4f804cd70 (diff)
downloadfreebsd-ports-graphics-c5aec8674975b00cf2acc722975eac94ca5be878.tar.gz
freebsd-ports-graphics-c5aec8674975b00cf2acc722975eac94ca5be878.tar.zst
freebsd-ports-graphics-c5aec8674975b00cf2acc722975eac94ca5be878.zip
Add erc, an IRC client written entirely in elisp, for emacs.
PR: ports/63401 Submitted by: Dryice Liu <dryice@liu.com.cn>
Diffstat (limited to 'irc/erc/Makefile')
-rw-r--r--irc/erc/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/irc/erc/Makefile b/irc/erc/Makefile
new file mode 100644
index 00000000000..b99af71d845
--- /dev/null
+++ b/irc/erc/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: erc
+# Date created: 23 February 2004
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= erc
+PORTVERSION= 4.0
+CATEGORIES+= irc elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= erc
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= ERC is an Emacs InternetRelayChat client
+
+EMACS_PORT_NAME?= emacs21
+
+ERC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+
+do-install:
+ ${MKDIR} ${ERC_LISPDIR}
+.for i in *.el *.elc
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${ERC_LISPDIR}
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>