aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircd-hybrid
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2004-07-04 17:53:46 +0800
committererwin <erwin@FreeBSD.org>2004-07-04 17:53:46 +0800
commit95ba9421b75c36e1976484a0c67e21fdf2c65413 (patch)
treeccfa1ec4f6c80244b15b37658a927ad17528c4f4 /irc/ircd-hybrid
parent7af2dbff80d9ec81d288de7c5d21b0010d085f1b (diff)
downloadfreebsd-ports-graphics-95ba9421b75c36e1976484a0c67e21fdf2c65413.tar.gz
freebsd-ports-graphics-95ba9421b75c36e1976484a0c67e21fdf2c65413.tar.zst
freebsd-ports-graphics-95ba9421b75c36e1976484a0c67e21fdf2c65413.zip
Unclutter my previous attempt to on the fly patching by using
EXTRA_PATCHES and putting it in WRKDIR instead of the assumed read-only FILES-DIR. Noticed by: dosirak (via kris) Pointy hat to: erwin
Diffstat (limited to 'irc/ircd-hybrid')
-rw-r--r--irc/ircd-hybrid/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index dbc301d7381..3405dd1c93c 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+EXTRA_PATCHES= ${WRKDIR}/patch-include-config.h
#
# User Configurable Variables
@@ -85,7 +86,7 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/ircd-hybrid \
--messagedir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/messages \
pre-patch:
- @${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${FILESDIR}/patch-include-config.h
+ @${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${WRKDIR}/patch-include-config.h
post-patch:
@${REINPLACE_CMD} -e "s#man8#man/man8#" ${WRKSRC}/doc/Makefile.in
@@ -103,7 +104,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/ircd-hybrid.sh ${PREFIX}/etc/rc.d
@${SED} -e "s#/usr/local/#${PREFIX}/#" ${PKGMESSAGE}
-pre-clean:
- @${RM} -f ${FILESDIR}/patch-include-config.h
-
.include <bsd.port.mk>