aboutsummaryrefslogtreecommitdiffstats
path: root/irc/p5-IRC
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2001-06-13 20:30:57 +0800
committerkuriyama <kuriyama@FreeBSD.org>2001-06-13 20:30:57 +0800
commit31b12056bee5736325f292bdd980d37a2176b19f (patch)
treefdbe22470c3f2487f3a28ba89fbd2a05078a92eb /irc/p5-IRC
parentfa81fe5243457013119c3505a5d799d879f0e8f3 (diff)
downloadfreebsd-ports-graphics-31b12056bee5736325f292bdd980d37a2176b19f.tar.gz
freebsd-ports-graphics-31b12056bee5736325f292bdd980d37a2176b19f.tar.zst
freebsd-ports-graphics-31b12056bee5736325f292bdd980d37a2176b19f.zip
Fix mismatching IPv6 numeric address.
Approved by: maintainer
Diffstat (limited to 'irc/p5-IRC')
-rw-r--r--irc/p5-IRC/Makefile1
-rw-r--r--irc/p5-IRC/files/patch-Connection.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/p5-IRC/Makefile b/irc/p5-IRC/Makefile
index 645eb55e84a..ca635d583fc 100644
--- a/irc/p5-IRC/Makefile
+++ b/irc/p5-IRC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-IRC
PORTVERSION= 0.70
+PORTREVISION= 1
CATEGORIES= irc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
diff --git a/irc/p5-IRC/files/patch-Connection.pm b/irc/p5-IRC/files/patch-Connection.pm
new file mode 100644
index 00000000000..8fcabb849ef
--- /dev/null
+++ b/irc/p5-IRC/files/patch-Connection.pm
@@ -0,0 +1,11 @@
+--- Connection.pm.orig Tue May 30 07:12:02 2000
++++ Connection.pm Wed Jun 13 17:01:06 2001
+@@ -1101,7 +1101,7 @@
+ /x) # That ought to do it for now...
+ {
+ $line = substr $line, 1 if $line =~ /^:/;
+- ($from, $line) = split ":", $line, 2;
++ ($from, $line) = $line =~ m/^(.*):(.*?)$/;
+ ($from, $type, @stuff) = split /\s+/, $from;
+ $type = lc $type;
+