aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
committertg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
commit3a84881f168162a487490bbbd275ca05b7f5560d (patch)
treee888acd7e17d635c1f902fccb1eefdf89f15641a /irc
parent83513fef56c1c9996eb040a93488ed7837fac927 (diff)
downloadfreebsd-ports-graphics-3a84881f168162a487490bbbd275ca05b7f5560d.tar.gz
freebsd-ports-graphics-3a84881f168162a487490bbbd275ca05b7f5560d.tar.zst
freebsd-ports-graphics-3a84881f168162a487490bbbd275ca05b7f5560d.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Diffstat (limited to 'irc')
-rw-r--r--irc/irc/Makefile5
-rw-r--r--irc/irc/files/ircd.sh15
-rw-r--r--irc/ircd-hybrid/files/ircd.sh19
3 files changed, 32 insertions, 7 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index f4f663b8f1d..d202064175f 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -50,10 +50,7 @@ do-install:
post-install:
@if [ ! -f ${STARTUP_SCRIPT} ]; then \
${ECHO} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${ECHO} '#!/bin/sh' > ${STARTUP_SCRIPT}; \
- ${ECHO} "[ -f ${PREFIX}/etc/ircd/ircd.conf ] && ${PREFIX}/sbin/ircd && ${ECHO} -n ' ircd'" >> ${STARTUP_SCRIPT} ; \
- ${CHMOD} 755 ${STARTUP_SCRIPT} ; \
- ${CHOWN} bin.bin ${STARTUP_SCRIPT}; \
+ ${INSTALL_SCRIPT} ${FILESDIR}/ircd.sh ${STARTUP_SCRIPT};\
fi
.include <bsd.port.post.mk>
diff --git a/irc/irc/files/ircd.sh b/irc/irc/files/ircd.sh
new file mode 100644
index 00000000000..530cc0e5228
--- /dev/null
+++ b/irc/irc/files/ircd.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ [ -f %%PREFIX%%/etc/ircd/ircd.conf ] && %%PREFIX%%/sbin/ircd && echo -n ' ircd'
+ ;;
+stop)
+ killall ircd && echo -n ' ircd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/irc/ircd-hybrid/files/ircd.sh b/irc/ircd-hybrid/files/ircd.sh
index c594f090e1d..9fb77f36bb4 100644
--- a/irc/ircd-hybrid/files/ircd.sh
+++ b/irc/ircd-hybrid/files/ircd.sh
@@ -1,4 +1,17 @@
#!/bin/sh
-[ -x /usr/local/sbin/ircd ] \
-&& /usr/local/sbin/ircd >/dev/null 2>&1 \
-&& echo -n " ircd"
+
+case "$1" in
+start)
+ [ -x /usr/local/sbin/ircd ] \
+ && /usr/local/sbin/ircd >/dev/null 2>&1 \
+ && echo -n " ircd"
+stop)
+ killall ircd && echo -n ' ircd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0