aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-16 00:54:14 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-16 00:54:14 +0800
commitb5bbd3457109f3b3ce4c180ebcdc4206da63c9bb (patch)
tree3a1bce119a552518303ac309502e995103aefd55 /irc
parent8cf2a0d43625163f65d7fb9d746adab3448f305e (diff)
downloadfreebsd-ports-graphics-b5bbd3457109f3b3ce4c180ebcdc4206da63c9bb.tar.gz
freebsd-ports-graphics-b5bbd3457109f3b3ce4c180ebcdc4206da63c9bb.tar.zst
freebsd-ports-graphics-b5bbd3457109f3b3ce4c180ebcdc4206da63c9bb.zip
- use OPTIONS_DEFINE
Diffstat (limited to 'irc')
-rw-r--r--irc/iroffer-dinoex/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index dbf09c164fc..253826d1a15 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -44,26 +44,24 @@ IROFFER_EXAMPLES= iroffer.cron \
IROFFER_HTDOCS= iroffer-state.css robots.txt \
info.txt.rb md5.txt.rb sfv.txt.rb
-OPTIONS= CURL "build ftp/http support" on \
- RUBY "build RUBY script support" on \
- UPNP "build UPNP support" on \
- GEOIP "build GEOIP support" on \
+OPTIONS_DEFINE= CURL RUBY UPNP GEOIP
+OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= -curl
.endif
-.if !defined(WITHOUT_GEOIP)
+.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= -geoip
.endif
-.if !defined(WITHOUT_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= miniupnpc:${PORTSDIR}/net/miniupnpc
CONFIGURE_ARGS+= -upnp
.endif
-.if !defined(WITHOUT_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
CONFIGURE_ARGS+= -ruby
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
@@ -92,4 +90,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/iroffer.1 ${PREFIX}/man/man1/
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>