aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-18 08:25:14 +0800
committermiwi <miwi@FreeBSD.org>2013-02-18 08:25:14 +0800
commitdaa813518a025e74fae94ad72144c9221b60141d (patch)
tree1610529241f5ec5312ead8062a5d74771ce16764 /irc
parenteb48a7172242d44050eddd1b47ab48d71c66c3c6 (diff)
downloadfreebsd-ports-graphics-daa813518a025e74fae94ad72144c9221b60141d.tar.gz
freebsd-ports-graphics-daa813518a025e74fae94ad72144c9221b60141d.tar.zst
freebsd-ports-graphics-daa813518a025e74fae94ad72144c9221b60141d.zip
- Switch to USE_GITHUB
- While here trim header
Diffstat (limited to 'irc')
-rw-r--r--irc/inspircd/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index a3e9730207d..6dab943a18f 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -1,10 +1,9 @@
+# Created by: brain
# $FreeBSD$
PORTNAME= inspircd
PORTVERSION= 2.0.10
CATEGORIES= irc
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/
-DISTNAME= v${PORTVERSION}
MAINTAINER= feld@feld.me
COMMENT= A modular C++ IRC daemon
@@ -14,7 +13,12 @@ LICENSE_FILE= ${WRKSRC}/docs/COPYING
CONFLICTS= inspircd-1.*
-FETCH_ARGS?= -pRr
+USE_GITHUB= yes
+GH_ACCOUNT= inspircd
+GH_PROJECT= ${GH_ACCOUNT}
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= d1cc59f
+
USE_RC_SUBR= ${PORTNAME}
MAKEFILE= BSDmakefile
@@ -53,9 +57,6 @@ POSIX_DESC= Build m_regex_posix module
.include <bsd.port.options.mk>
-post-extract:
- @(cd ${WRKDIR} && ${MV} inspircd-${PORTVERSION} ${DISTNAME})
-
.if ${PORT_OPTIONS:MLDAPAUTH}
USE_OPENLDAP= yes
EXTRAS:=${EXTRAS},m_ldapauth.cpp