aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/a2ps
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
committermat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
commit344522393988339d341fda0818f0281645323f90 (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /japanese/a2ps
parenta8ea83538e74965157afe830f9873190be5ac78a (diff)
downloadfreebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.tar.gz
freebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.tar.zst
freebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Diffstat (limited to 'japanese/a2ps')
-rw-r--r--japanese/a2ps/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/japanese/a2ps/Makefile b/japanese/a2ps/Makefile
index e53bfa84802..7f5d2ef493e 100644
--- a/japanese/a2ps/Makefile
+++ b/japanese/a2ps/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= paperconf:${PORTSDIR}/print/libpaper
USES= perl5 shebangfix
USE_PERL5= run
-SHEBANG_FILES= ${WRKDIR}/a2ps-j
+SHEBANG_FILES= ${WRKSRC}/a2ps-j
perl_OLD_CMD= /usr/local/bin/perl
PLIST_FILES= bin/a2ps-j
EXTRACT_CMD= ${INSTALL_SCRIPT}
@@ -29,9 +29,9 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
post-patch:
- ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKDIR}/a2ps-j
+ ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/a2ps-j
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/a2ps-j ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/a2ps-j ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>