aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/citrix_ica
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-04 02:49:55 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-04 02:49:55 +0800
commit24fbacca1dfef2d79fa1d033a760aa8a5d5fb14b (patch)
tree85d722355ca7a637685ab3981e297c1bcbbbbc43 /japanese/citrix_ica
parent4ddaab252ed89fbca544417424f95611024a61e9 (diff)
downloadfreebsd-ports-graphics-24fbacca1dfef2d79fa1d033a760aa8a5d5fb14b.tar.gz
freebsd-ports-graphics-24fbacca1dfef2d79fa1d033a760aa8a5d5fb14b.tar.zst
freebsd-ports-graphics-24fbacca1dfef2d79fa1d033a760aa8a5d5fb14b.zip
Citrix(R) Presentation Server(TM) runs on Microsoft(R) Windows
Server(TM) and UNIX(R) operating systems, and extends the base Windows Terminal Services platform by enhancing the end-user experience as well as increasing manageability, compatibility, security and scalability to address business-critical environments. Presentation Server expands the range of supported applications to include legacy software and Web-based, UNIX and Java solutions. It also enables any device or operating system including Macintosh and Linux to access virtualized applications. Other important capabilities are powerful management and configuration tools and faster, more flexible printing. WWW: http://www.citrix.com/English/ps2/products/product.asp?contentID=186 PR: ports/98299 Submitted by: Thomas Abthorpe <thomas at goodking.ca>
Diffstat (limited to 'japanese/citrix_ica')
-rw-r--r--japanese/citrix_ica/Makefile85
-rw-r--r--japanese/citrix_ica/distinfo3
-rw-r--r--japanese/citrix_ica/files/patch-linuxx86__hinst166
-rw-r--r--japanese/citrix_ica/files/patch-setupwfc11
-rw-r--r--japanese/citrix_ica/files/wfcmgr3
-rw-r--r--japanese/citrix_ica/files/wfica3
-rw-r--r--japanese/citrix_ica/pkg-descr13
-rw-r--r--japanese/citrix_ica/pkg-plist142
8 files changed, 426 insertions, 0 deletions
diff --git a/japanese/citrix_ica/Makefile b/japanese/citrix_ica/Makefile
new file mode 100644
index 00000000000..4b0596c2748
--- /dev/null
+++ b/japanese/citrix_ica/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: Citrix(R) ICA(R) Client
+# Date created: 2006-05-31
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= citrix_ica
+PORTVERSION= 9.15
+CATEGORIES= japanese net comms linux
+MASTER_SITES=
+DISTNAME= ${PORTNAME}-linuxx86-ja-${PORTVERSION}
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= Citrix(R) Presentation Server(TM) client
+
+RUN_DEPENDS= ${LINUXBASE}${X11BASE}/lib/libXm.so.3:${PORTSDIR}/x11-toolkits/linux-openmotif
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+#USE_X_PREFIX= Yes
+RESTRICTED= License prohibits redistribution
+IS_INTERACTIVE= "Noisy license agreement ignores stdin"
+
+NO_WRKSUBDIR= Yes
+NO_BUILD= Yes
+
+CDIR= ${PREFIX}/ICAClient
+BINDIR= ${PREFIX}/bin
+
+NSCP= ${LOCALBASE}/libexec/netscape \
+ ${LOCALBASE}/libexec/netscape-linux \
+ ${LOCALBASE}/netscape \
+ ${LOCALBASE}/netscape-linux \
+ ${LOCALBASE}/lib/netscape \
+ ${LOCALBASE}/lib/netscape-linux \
+ ${MOZILLA_HOME}
+
+PLIST_SUB= MOZILLA_HOME=${MOZILLA_HOME}
+
+.include <bsd.port.pre.mk>
+
+.if exists(${PREFIX}/bin/kde-config)
+HAVE_KDE= "\\ny"
+.endif
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions.'
+.endif
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ @${ECHO} ""
+ @${ECHO} "You have to fetch the file manually after reading and"
+ @${ECHO} "agreeing to the license at:"
+ @${ECHO} ""
+ @${ECHO} "http://www.citrix.com/download/bin/license.asp?client=linux"
+ @${ECHO} ""
+ @${ECHO} "Once linuxx86.tar.gz has been downloaded move it to"
+ @${ECHO} "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} and restart the build."
+ @${ECHO} ""
+ @${FALSE}
+.endif
+
+do-install:
+ @if (test -d "${CDIR}") ; \
+ then \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "A ${CDIR} installation does already exist." ; \
+ ${ECHO} "Please move it away or delete the old port" ; \
+ ${ECHO} "" ; \
+ ${ECHO} "-----------------------------------------------------------" ; \
+ ${FALSE} ; \
+ fi
+ ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
+ > ${WRKSRC}/wfcmgr.x
+ ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
+ > ${WRKSRC}/wfica.x
+ cd ${WRKSRC} && ${SH} -c './setupwfc'
+ ${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
+ ${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
+
+.include <bsd.port.post.mk>
diff --git a/japanese/citrix_ica/distinfo b/japanese/citrix_ica/distinfo
new file mode 100644
index 00000000000..3f77346211b
--- /dev/null
+++ b/japanese/citrix_ica/distinfo
@@ -0,0 +1,3 @@
+MD5 (citrix_ica-linuxx86-ja-9.15.tar.gz) = aa9043263f29d450edda08fd0d4bbe1e
+SHA256 (citrix_ica-linuxx86-ja-9.15.tar.gz) = 892526bc03dc05c6558e4b5f6ea4e6165cc2624a374185c59aa28fb33f2ed451
+SIZE (citrix_ica-linuxx86-ja-9.15.tar.gz) = 1385839
diff --git a/japanese/citrix_ica/files/patch-linuxx86__hinst b/japanese/citrix_ica/files/patch-linuxx86__hinst
new file mode 100644
index 00000000000..d4bb89ccae8
--- /dev/null
+++ b/japanese/citrix_ica/files/patch-linuxx86__hinst
@@ -0,0 +1,166 @@
+--- linuxx86/hinst.orig Tue Dec 6 10:50:57 2005
++++ linuxx86/hinst Thu Jun 1 08:58:24 2006
+@@ -74,7 +74,7 @@
+ fi
+
+ # Install in here by default.
+-DefaultInstallDir=/usr/lib/ICAClient
++DefaultInstallDir=/usr/local/ICAClient
+
+ # Default CDROM mount point
+ DefaultCDSourceDir=/cdrom
+@@ -2172,7 +2172,7 @@
+ tr_file $TR_FILE_KEY $PORT/$PORT.psf
+ preen_files
+
+- /bin/true
++ /usr/bin/true
+ }
+
+ ###############################################################################
+@@ -2222,10 +2222,34 @@
+ #
+ ###############################################################################
+
++check_for_ns() {
++ BIN=`/usr/bin/file $1/plugins/libnullplugin.so | /usr/bin/awk '{print $11}'`
++ case ${BIN} in
++ \(SYSV\),)
++ NETSCAPE_DIR="$1"
++ PLUGIN_PATH="$s/plugins"
++ FOUND_NS="TRUE"
++ esac
++}
++
++NSCP="/usr/local/libexec/netscape \
++ /usr/local/libexec/netscape-linux \
++ /usr/local/netscape \
++ /usr/local/netscape-linux \
++ /usr/local/lib/netscape \
++ /usr/local/lib/netscape-linux \
++ /usr/local/lib/linux-mozilla \
++ /usr/local/lib/mozilla \
++ $MOZILLA_HOME"
++
++for dir in ${NSCP}; do
++ if [ -e $dir/plugins/libnullplugin.so ]; then
++ check_for_ns $dir;
++ fi
++done
++
+ INST_DIR=$ICAInstDir
+ TMP_NAME=/tmp/ICAnetscape.$$
+-NETSCAPE_DIR="/usr/local/lib/netscape"
+-PLUGIN_PATH="/usr/local/netscape/plugins"
+ PLUGIN_NAME=npica.so
+ PLUGIN_CLASS=ICAClObj.class
+ MAILCAP_FILE=mailcap
+@@ -2298,26 +2322,18 @@
+
+ netscape_integrate()
+ {
+- user_echo $integrate_netscape1
+ if test -z "$SU_INSTALL"
+ then
+ set_npui_variables
+ found_netscape
+ else
+ search_ok=0
+- EXTRA_BROWSERS=`find_browsers`
+-
+- if test -d "/usr/lib/netscape"\
+- || test -d "/usr/local/netscape"\
+- || test -d "/opt/netscape"\
+- || test -d "/usr/local/lib/netscape"\
+- || test -d "/usr/dt/appconfig/netscape"\
+- || test "$MOZILLA_HOME" != "" -a -d "$MOZILLA_HOME"\
+- || test "$EXTRA_BROWSERS" != ""
+- then
++ case ${FOUND_NS} in
++ TRUE)
+ user_echo $integrate_netscape3
+ found_netscape
+- else
++ ;;
++ *)
+ user_prompt $integrate_netscape2
+ getyesno $INSTALLER_NO
+ if [ "$ANSWER" = "$INSTALLER_YES" ]
+@@ -2326,7 +2342,8 @@
+ else
+ user_echo $integrate_netscape6
+ fi
+- fi
++ ;;
++ esac
+ fi
+
+ # Create utility script files in install root.
+@@ -2964,55 +2981,6 @@
+ echo "$BINDIR"
+ }
+
+-################################################################################
+-#
+-# find_browsers
+-#
+-# Returns a list of directories containing new-style mozilla-based browsers
+-# that may be launched by files on the $PATH.
+-#
+-################################################################################
+-find_browsers()
+-{
+- PROGS="netscape mozilla firefox"
+- DIST_BIN_DIR=""
+- STANDARD_DIRS="/usr/local/netscape /usr/local/mozilla /usr/local/firefox /usr/lib/mozilla"
+-
+- case $op_system in
+- SunOS) if
+- /usr/bin/pkginfo -q $SOLARIS_PACKAGE_NAME
+- then
+- relocation_base=`/usr/bin/pkginfo -r $SOLARIS_PACKAGE_NAME`
+- STANDARD_DIRS="$STANDARD_DIRS $relocation_base/$SOLARIS_PACKAGE_DIRECTORY"
+-
+- # N.B. the Netscape 7 packages for SOLARIS 9 have an extended installation path built-in!
+- case `uname -r` in
+- 5.9) STANDARD_DIRS="$STANDARD_DIRS $relocation_base/dt/appconfig/$SOLARIS_PACKAGE_DIRECTORY"
+- ;;
+- *) ;;
+- esac
+- fi;;
+- *) ;;
+- esac
+-
+- for d in `echo $PATH | sed "s/:/ /g"` $STANDARD_DIRS
+- do
+- echo $d
+- done | sort -u | while read d
+- do
+- for p in $PROGS
+- do
+- # Find the each instance of each named browser
+- PROG=$d/$p
+- if test -f $PROG
+- then
+- # Where is the installation and what version is it?
+- find_extra_bin_dirs $PROG
+- fi
+- done
+- done | sort -u
+-}
+-
+ BROWSER_LIST_KEY="BROWSER_DIR"
+ ################################################################################
+ #
+@@ -3238,7 +3206,10 @@
+ XDG_TARGET_DIR="/usr/share/applications"
+ TL_MENU_DIR="Vendor_menus/Applications" # TurboLinux
+ TL_TOP_DIR="/usr/share/applnk/"$TL_MENU_DIR
+-DEFAULT_GNOME_TARGET_DIRS="/etc/opt/gnome/SuSE/Internet"
++EFAULT_GNOME_TARGET_DIRS="/usr/share/applications \
++ /usr/local/share/applnk/Internet \
++ /usr/local/share/applnk/Networking \
++ /etc/opt/gnome/SuSE/Internet"
+ DEFAULT_KDE_TARGET_DIRS="/usr/share/applnk-redhat/Internet \
+ /usr/share/applnk-mdk/Networking \
+ $TL_TOP_DIR/Internet \
diff --git a/japanese/citrix_ica/files/patch-setupwfc b/japanese/citrix_ica/files/patch-setupwfc
new file mode 100644
index 00000000000..5cd313afea7
--- /dev/null
+++ b/japanese/citrix_ica/files/patch-setupwfc
@@ -0,0 +1,11 @@
+--- setupwfc.orig Tue Dec 6 11:25:39 2005
++++ setupwfc Fri May 26 10:15:09 2006
+@@ -420,7 +420,7 @@
+ # We assume that an Intel-based linux system will have an x86
+ # processor. We also assume that this is reported by uname -m
+ # "ix86" where x is some number.
+- if uname -m | grep 86 2>&1 >/dev/null ;then
++ if uname -m | grep i[3456]86 2>&1 >/dev/null ;then
+ if grep uClibc /etc/issue 2>&1 > /dev/null ;then
+ PLATFORM=uclibc
+ DISP_PLATFORM="Linux (uClibc)"
diff --git a/japanese/citrix_ica/files/wfcmgr b/japanese/citrix_ica/files/wfcmgr
new file mode 100644
index 00000000000..70248171d68
--- /dev/null
+++ b/japanese/citrix_ica/files/wfcmgr
@@ -0,0 +1,3 @@
+#!/bin/sh
+export ICAROOT=DESTINATION
+exec $ICAROOT/wfcmgr
diff --git a/japanese/citrix_ica/files/wfica b/japanese/citrix_ica/files/wfica
new file mode 100644
index 00000000000..e0279ba0d81
--- /dev/null
+++ b/japanese/citrix_ica/files/wfica
@@ -0,0 +1,3 @@
+#!/bin/sh
+export ICAROOT=DESTINATION
+exec $ICAROOT/wfica "$@"
diff --git a/japanese/citrix_ica/pkg-descr b/japanese/citrix_ica/pkg-descr
new file mode 100644
index 00000000000..69deced9f26
--- /dev/null
+++ b/japanese/citrix_ica/pkg-descr
@@ -0,0 +1,13 @@
+Citrix(R) Presentation Server(TM) runs on Microsoft(R) Windows
+Server(TM) and UNIX(R) operating systems, and extends the base
+Windows Terminal Services platform by enhancing the end-user
+experience as well as increasing manageability, compatibility,
+security and scalability to address business-critical environments.
+Presentation Server expands the range of supported applications to
+include legacy software and Web-based, UNIX and Java solutions. It
+also enables any device or operating system including Macintosh and
+Linux to access virtualized applications. Other important capabilities
+are powerful management and configuration tools and faster, more
+flexible printing.
+
+WWW: http://www.citrix.com/English/ps2/products/product.asp?contentID=186
diff --git a/japanese/citrix_ica/pkg-plist b/japanese/citrix_ica/pkg-plist
new file mode 100644
index 00000000000..aca66eb7342
--- /dev/null
+++ b/japanese/citrix_ica/pkg-plist
@@ -0,0 +1,142 @@
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -f ${dir}/mime.types ]; then (/bin/cat ${dir}/mime.types | /usr/bin/grep -v "application/x-ica" > ${dir}/mime.types.tmp; mv ${dir}/mime.types.tmp ${dir}/mime.types); fi ; done
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -f ${dir}/mailcap ]; then (/bin/cat ${dir}/mailcap | /usr/bin/grep -v "application/x-ica" > ${dir}/mailcap.tmp; /bin/mv ${dir}/mailcap.tmp ${dir}/mailcap); fi ; done
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -e ${dir}/plugins/npica.so ]; then (/bin/rm ${dir}/plugins/npica.so); fi ; done
+ICAClient/.config/appsrv.ini
+ICAClient/.config/keyboard.ini
+ICAClient/.config/module.ini
+ICAClient/.config/wfclient.ini
+ICAClient/libctxssl.so
+ICAClient/Npica
+ICAClient/Npica.ad
+ICAClient/CHARICONV.DLL
+ICAClient/NDS.DLL
+ICAClient/PDCRYPT1.DLL
+ICAClient/PDCRYPT2.DLL
+ICAClient/TW1.DLL
+ICAClient/VDCM.DLL
+ICAClient/VDSCARD.DLL
+ICAClient/VDSPMIKE.DLL
+ICAClient/Wfcmgr
+ICAClient/Wfcmgr.ad
+ICAClient/Wfica
+ICAClient/Wfica.ad
+ICAClient/config/.server
+ICAClient/config/appsrv.ini
+ICAClient/config/module.ini
+ICAClient/config/wfclient.ini
+ICAClient/desktop/wfcmgr.desktop
+ICAClient/desktop/Citrix_PNA.desktop
+ICAClient/eula.txt
+ICAClient/help/index.htm
+ICAClient/icons/citrix16.xpm
+ICAClient/icons/citrix32.xpm
+ICAClient/icons/citrix48.xpm
+ICAClient/install.txt
+ICAClient/keyboard/age2.kbd
+ICAClient/keyboard/agex2.kbd
+ICAClient/keyboard/automatic.kbd
+ICAClient/keyboard/dcint401.kbd
+ICAClient/keyboard/dcintpcx.kbd
+ICAClient/keyboard/dcus401.kbd
+ICAClient/keyboard/dcuspcx.kbd
+ICAClient/keyboard/dec401.kbd
+ICAClient/keyboard/dec401uk.kbd
+ICAClient/keyboard/decpcx.kbd
+ICAClient/keyboard/decpcxuk.kbd
+ICAClient/keyboard/dg.kbd
+ICAClient/keyboard/dgfr.kbd
+ICAClient/keyboard/dggr.kbd
+ICAClient/keyboard/dguk.kbd
+ICAClient/keyboard/dgus.kbd
+ICAClient/keyboard/hp101.kbd
+ICAClient/keyboard/hpfritf.kbd
+ICAClient/keyboard/hpgritf.kbd
+ICAClient/keyboard/hpint101.kbd
+ICAClient/keyboard/hpintps2.kbd
+ICAClient/keyboard/hpitf.kbd
+ICAClient/keyboard/hpps2.kbd
+ICAClient/keyboard/hpuk101.kbd
+ICAClient/keyboard/hpukitf.kbd
+ICAClient/keyboard/hpukps2.kbd
+ICAClient/keyboard/hpus101.kbd
+ICAClient/keyboard/hpusitf.kbd
+ICAClient/keyboard/hpusps2.kbd
+ICAClient/keyboard/ibm.kbd
+ICAClient/keyboard/keyboard.ini
+ICAClient/keyboard/linux.kbd
+ICAClient/keyboard/linux-ja.kbd
+ICAClient/keyboard/mac101.kbd
+ICAClient/keyboard/ncdn-101.kbd
+ICAClient/keyboard/ncdn-102.kbd
+ICAClient/keyboard/netbsd.kbd
+ICAClient/keyboard/scoos5.kbd
+ICAClient/keyboard/scouw2.kbd
+ICAClient/keyboard/sg.kbd
+ICAClient/keyboard/sgindy.kbd
+ICAClient/keyboard/sgindyfr.kbd
+ICAClient/keyboard/sgindygr.kbd
+ICAClient/keyboard/sgindyuk.kbd
+ICAClient/keyboard/sgindyus.kbd
+ICAClient/keyboard/sngr.kbd
+ICAClient/keyboard/sparc3.kbd
+ICAClient/keyboard/sparc4.kbd
+ICAClient/keyboard/sparc5.kbd
+ICAClient/keyboard/sparc6usb.kbd
+ICAClient/keyboard/sparcfr4.kbd
+ICAClient/keyboard/sparcfr5.kbd
+ICAClient/keyboard/sparcgr4.kbd
+ICAClient/keyboard/sparcgr5.kbd
+ICAClient/keyboard/sparcuk4.kbd
+ICAClient/keyboard/sparcuk5.kbd
+ICAClient/keyboard/sparcus3.kbd
+ICAClient/keyboard/sparcus4.kbd
+ICAClient/keyboard/sparcus5.kbd
+ICAClient/keyboard/trimodal.kbd
+ICAClient/keystore/cacerts/BTCTRoot.crt
+ICAClient/keystore/cacerts/Class3PCA_G2_v2.crt
+ICAClient/keystore/cacerts/Class4PCA_G2_v2.crt
+ICAClient/keystore/cacerts/GTECTGlobalRoot.crt
+ICAClient/keystore/cacerts/GTECTRoot.crt
+ICAClient/keystore/cacerts/Pcs3ss_v4.crt
+ICAClient/keystore/cacerts/SecureServer.crt
+ICAClient/nls/C
+ICAClient/nls/ja/pna.nls
+ICAClient/nls/en/pna.nls
+ICAClient/npica.so
+ICAClient/pkginf/F.core.linuxx86
+ICAClient/pkginf/Ver.core.linuxx86
+ICAClient/pkginf/changeno.dat
+ICAClient/readme.txt
+ICAClient/setupwfc
+ICAClient/util/XCapture
+ICAClient/util/XCapture.ad
+ICAClient/util/echo_cmd
+ICAClient/util/hinst
+ICAClient/util/icalicense.sh
+ICAClient/util/nslaunch
+ICAClient/util/pacexec
+ICAClient/util/pac.js
+ICAClient/util/xcapture
+ICAClient/wfcmgr
+ICAClient/wfica
+ICAClient/wfica.sh
+ICAClient/wfica_assoc.sh
+bin/wfcmgr
+bin/wfica
+@dirrm ICAClient/.config
+@dirrm ICAClient/cache/zlcache
+@unexec find %D/ICAClient/cache/ -type f -exec rm {} \; 2>&1 >/dev/null || true
+@dirrm ICAClient/cache
+@dirrm ICAClient/config
+@dirrm ICAClient/desktop
+@dirrm ICAClient/help
+@dirrm ICAClient/icons
+@dirrm ICAClient/keyboard
+@dirrm ICAClient/keystore/cacerts
+@dirrm ICAClient/keystore
+@dirrm ICAClient/nls/ja
+@dirrm ICAClient/nls/en
+@dirrm ICAClient/nls
+@dirrm ICAClient/pkginf
+@dirrm ICAClient/util
+@dirrm ICAClient