aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/citrix_xenapp
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2010-01-25 23:12:57 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2010-01-25 23:12:57 +0800
commitc5ab5b708c785f7f5845d91db2450681b11f7639 (patch)
tree1aea70db465ee245d1e27a41a3b2609f0ad8318e /japanese/citrix_xenapp
parent3357204e474852a4d1f402eec0aa61d725b29182 (diff)
downloadfreebsd-ports-graphics-c5ab5b708c785f7f5845d91db2450681b11f7639.tar.gz
freebsd-ports-graphics-c5ab5b708c785f7f5845d91db2450681b11f7639.tar.zst
freebsd-ports-graphics-c5ab5b708c785f7f5845d91db2450681b11f7639.zip
- Use SUB_FILES/LIST in lieu of sed
- No PORTREVISION bump needed PR: ports/143104 Submitted by: Sevan Janiyan <venture37 geeklan.co.uk>
Diffstat (limited to 'japanese/citrix_xenapp')
-rw-r--r--japanese/citrix_xenapp/Makefile11
-rw-r--r--japanese/citrix_xenapp/files/wfcmgr.in (renamed from japanese/citrix_xenapp/files/wfcmgr)2
-rw-r--r--japanese/citrix_xenapp/files/wfica.in (renamed from japanese/citrix_xenapp/files/wfica)2
3 files changed, 7 insertions, 8 deletions
diff --git a/japanese/citrix_xenapp/Makefile b/japanese/citrix_xenapp/Makefile
index ee797030945..d98547db3f1 100644
--- a/japanese/citrix_xenapp/Makefile
+++ b/japanese/citrix_xenapp/Makefile
@@ -34,6 +34,9 @@ PLIST_SUB+= HAVE_ICA_CERTS="" ICA_CERTS="${ICA_CERTS}" CERTDIR="${CERTDIR}"
PLIST_SUB+= HAVE_ICA_CERTS="@comment "
.endif
+SUB_FILES= wfcmgr wfica
+SUB_LIST= CDIR=${CDIR}
+
.include <bsd.port.pre.mk>
.if defined(BATCH) || defined(PACKAGE_BUILDING)
@@ -78,13 +81,9 @@ do-install:
${ECHO} "-----------------------------------------------------------" ; \
${FALSE} ; \
fi
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
- > ${WRKSRC}/wfcmgr.x
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
- > ${WRKSRC}/wfica.x
cd ${WRKSRC} && ${SH} -c './setupwfc'
- ${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
- ${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+ ${INSTALL_SCRIPT} ${WRKDIR}/wfcmgr ${PREFIX}/bin/wfcmgr
+ ${INSTALL_SCRIPT} ${WRKDIR}/wfica ${PREFIX}/bin/wfica
${MKDIR} ${LINUXBASE}/dev
# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
diff --git a/japanese/citrix_xenapp/files/wfcmgr b/japanese/citrix_xenapp/files/wfcmgr.in
index 70248171d68..6c28ad60148 100644
--- a/japanese/citrix_xenapp/files/wfcmgr
+++ b/japanese/citrix_xenapp/files/wfcmgr.in
@@ -1,3 +1,3 @@
#!/bin/sh
-export ICAROOT=DESTINATION
+export ICAROOT=%%CDIR%%
exec $ICAROOT/wfcmgr
diff --git a/japanese/citrix_xenapp/files/wfica b/japanese/citrix_xenapp/files/wfica.in
index e0279ba0d81..d120da57817 100644
--- a/japanese/citrix_xenapp/files/wfica
+++ b/japanese/citrix_xenapp/files/wfica.in
@@ -1,3 +1,3 @@
#!/bin/sh
-export ICAROOT=DESTINATION
+export ICAROOT=%%CDIR%%
exec $ICAROOT/wfica "$@"