aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/font-shinonome
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2009-05-31 21:03:28 +0800
committerhrs <hrs@FreeBSD.org>2009-05-31 21:03:28 +0800
commit3ca1756fc581470f66661ff708c36aa8f2f030c6 (patch)
tree365596ab585e3879823e29c179380307537ae712 /japanese/font-shinonome
parent356f9a43320a632df10614dba122135f1fa6eb21 (diff)
downloadfreebsd-ports-graphics-3ca1756fc581470f66661ff708c36aa8f2f030c6.tar.gz
freebsd-ports-graphics-3ca1756fc581470f66661ff708c36aa8f2f030c6.tar.zst
freebsd-ports-graphics-3ca1756fc581470f66661ff708c36aa8f2f030c6.zip
- Add missing dependency.
- Fix typo in PKG{,DE}INSTALL line. - Remove ^!! line from fonts.alias. - Use POST-DEINSTALL instead of DEINSTALL because mkfontdir(1) is used for generating fonts.dir.
Diffstat (limited to 'japanese/font-shinonome')
-rw-r--r--japanese/font-shinonome/Makefile7
-rw-r--r--japanese/font-shinonome/files/pkg-install.in6
2 files changed, 8 insertions, 5 deletions
diff --git a/japanese/font-shinonome/Makefile b/japanese/font-shinonome/Makefile
index 284d2a10020..01fc3864a3d 100644
--- a/japanese/font-shinonome/Makefile
+++ b/japanese/font-shinonome/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= Shinonome Japanese fonts, 12/14/16 dots
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ fc-cache:${PORTSDIR}/x11-fonts/fontconfig
WRKSRC= ${WRKDIR}/${PORTNAME:C/^font-//}-${PORTVERSION:C/.p.*$//}
USE_BZIP2= yes
@@ -25,8 +26,8 @@ PLIST_SUB= X_FONTSDIR=${X_FONTSDIR} \
SUB_FILES= pkg-install
SUB_LIST= X_FONTSDIR=${PREFIX}/${X_FONTSDIR} \
FONTSALIAS=${DATADIR}/fonts.alias
-PKGINSTALL= pkg-install
-PKGDEINSTALL= pkg-install
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-install
PORTDOCS= AUTHORS BUGS ChangeLog ChangeLog.0 DESIGN.12 DESIGN.14 \
DESIGN.16 DESIGN.18 INSTALL README THANKS TODO LICENSE
diff --git a/japanese/font-shinonome/files/pkg-install.in b/japanese/font-shinonome/files/pkg-install.in
index fe75f621c96..df4a97d6f17 100644
--- a/japanese/font-shinonome/files/pkg-install.in
+++ b/japanese/font-shinonome/files/pkg-install.in
@@ -10,18 +10,20 @@ POST-INSTALL)
%%LOCALBASE%%/bin/mkfontdir ${X_FONTSDIR}/misc
touch fonts.alias
grep -v -- "-shinonome-" fonts.alias > fonts.alias.tmp
- cat fonts.alias.tmp %%FONTSALIAS%% > fonts.alias
+ (cat fonts.alias.tmp; grep -v "^!!" %%FONTSALIAS%%) > fonts.alias
rm -f fonts.alias.tmp
;;
-DEINSTALL)
+POST-DEINSTALL)
%%LOCALBASE%%/bin/fc-cache -f -v ${X_FONTSDIR}/misc
rm -f ${X_FONTSDIR}/misc/fonts.cache-1
cd ${X_FONTSDIR}/misc
+
%%LOCALBASE%%/bin/mkfontdir ${X_FONTSDIR}/misc
if [ -r ${X_FONTSDIR}/misc/fonts.dir -a `/usr/bin/wc -l < ${X_FONTSDIR}/misc/fonts.dir` = 1 ]; then
rm -f ${X_FONTSDIR}/misc/fonts.dir
fi
+
touch fonts.alias
grep -v -- "-shinonome-" fonts.alias > fonts.alias.tmp
if [ -s fonts.alias.tmp ]; then