aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/vfxdvi300
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
committerasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
commit71102e95212bab836c7a1f7b6a46879128507258 (patch)
tree092d32b70a72fb7f03924e677d49b93599639b89 /japanese/vfxdvi300
parent1adcc2f9a259e053ec9c8749e6e4ca4193bd4a56 (diff)
downloadfreebsd-ports-graphics-71102e95212bab836c7a1f7b6a46879128507258.tar.gz
freebsd-ports-graphics-71102e95212bab836c7a1f7b6a46879128507258.tar.zst
freebsd-ports-graphics-71102e95212bab836c7a1f7b6a46879128507258.zip
Remove LOOP_VAR and replace it with tiny Makefiles using MASTERDIR to
share most files. Repository copy the default to explicitly named directories to avoid any confusion. Greatly simplify the shared Makefiles, since we are now in different subdirectories, we don't need "a4-install" stuff. While I'm here, consistently name the variables. Here are the guidelines (master port is in brackets) DOCFORMAT: [html] pdf ps KONFONT: 14dot [16dot] PAPERSIZE: a4 [letter] letterdj RESOLUTION: 118 240 [300] 360 400 600 "math/r" has been copied to "R-a4" and "R-letter", to follow the spirit of the original port. "japanese/kon" is renamed to "kon2-*", since that seems to be the basename.
Diffstat (limited to 'japanese/vfxdvi300')
-rw-r--r--japanese/vfxdvi300/Makefile22
1 files changed, 5 insertions, 17 deletions
diff --git a/japanese/vfxdvi300/Makefile b/japanese/vfxdvi300/Makefile
index 0aece2c4e88..828fa360c3f 100644
--- a/japanese/vfxdvi300/Makefile
+++ b/japanese/vfxdvi300/Makefile
@@ -3,7 +3,7 @@
# Date created: 8 Nov 1996
# Whom: Mita Yoshio <mita@jp.FreeBSD.org>
#
-# $Id: Makefile,v 1.12 1998/10/30 10:31:44 asami Exp $
+# $Id: Makefile,v 1.13 1998/11/07 10:49:47 asami Exp $
#
DISTNAME= xdvi-17
@@ -23,8 +23,6 @@ MAINTAINER= mita@jp.FreeBSD.org
LIB_DEPENDS= VFlib2.23:${PORTSDIR}/japanese/vflib
RUN_DEPENDS= ${LOCALBASE}/lib/fonts/pk${RESOLUTION}:${PORTSDIR}/print/pkfonts${RESOLUTION}
-LOOP_VAR= RESOLUTION
-LOOP_OPTIONS= 118 240 300 360 400 600
WRKSRC= ${WRKDIR}
DIST_SUBDIR= xdvi
USE_IMAKE= yes
@@ -33,26 +31,16 @@ EXTRACT_ONLY= xdvi-17.tar.gz
.if !defined(RESOLUTION)
RESOLUTION= 300
-RESOLUTION_UNSPECIFIED= yes
.else
.if ${RESOLUTION} != 118 && ${RESOLUTION} != 240 && \
${RESOLUTION} != 300 && ${RESOLUTION} != 360 && \
${RESOLUTION} != 400 && ${RESOLUTION} != 600
-RESOLUTION_INVALID= yes
-.endif
-.endif
-
-pre-fetch:
-.if defined(RESOLUTION_UNSPECIFIED)
- @echo "Building xdvi with ${RESOLUTION}dpi fonts."
- @echo "Set the environment variable RESOLUTION if you want"
- @echo "it to use other resolutions."
- @echo "Possible values are: 118, 240, 300 (default), 360, 400 and 600."
-.elif defined(RESOLUTION_INVALID)
- @echo "Error: invalid value for RESOLUTION: \"${RESOLUTION}\""
- @echo "Possible values are: 118, 240, 300 (default), 360, 400 and 600."
+.BEGIN:
+ @${ECHO} "Error: invalid value for RESOLUTION: \"${RESOLUTION}\""
+ @${ECHO} "Possible values are: 118, 240, 300, 360, 400 and 600."
@${FALSE}
.endif
+.endif
pre-patch:
@(cd ${WRKDIR} ; \