aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/xv/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>1998-10-28 06:06:53 +0800
committerkuriyama <kuriyama@FreeBSD.org>1998-10-28 06:06:53 +0800
commit5bf51aac8adcab14fd19a1cf8f4e84d26edd67ec (patch)
tree2cecc47598a42d03fe5f40cd61485da793b9c3f2 /japanese/xv/Makefile
parent6dc1e122f8b080992b72fa83821e651206dc88fb (diff)
downloadfreebsd-ports-graphics-5bf51aac8adcab14fd19a1cf8f4e84d26edd67ec.tar.gz
freebsd-ports-graphics-5bf51aac8adcab14fd19a1cf8f4e84d26edd67ec.tar.zst
freebsd-ports-graphics-5bf51aac8adcab14fd19a1cf8f4e84d26edd67ec.zip
An X11 program that displays images of various formats with japanization.
PR: ports/8187 Submitted by: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
Diffstat (limited to 'japanese/xv/Makefile')
-rw-r--r--japanese/xv/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/japanese/xv/Makefile b/japanese/xv/Makefile
new file mode 100644
index 00000000000..48f18c4e7cf
--- /dev/null
+++ b/japanese/xv/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ja-xv
+# Version required: 3.10a
+# Date created: 07 Oct 1998
+# Whom: Shigeyuki FUKUSHIMA (shige@kuis.kyoto-u.ac.jp)
+#
+# $Id$
+#
+
+PKGNAME= ja-xv-3.10a
+CATEGORIES= japanese graphics
+
+MAINTAINER= shige@kuis.kyoto-u.ac.jp
+
+# can't use PORTSDIR here, since we haven't included bsd.port.mk
+FILESDIR= ${.CURDIR}/../../graphics/xv/files
+PATCHDIR= ${.CURDIR}/../../graphics/xv/patches
+
+MAKE_ENV= LOCALE_EXTENSION=-DTV_L10N
+
+RUN_DEPENDS= xv:${.CURDIR}/../../graphics/xv
+
+NOMAN= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/xv ${PREFIX}/bin/ja-xv
+ @if [ ! -f ${PREFIX}/bin/xv.orig ]; then \
+ ${MV} ${PREFIX}/bin/xv ${PREFIX}/bin/xv.orig ;\
+ else \
+ ${RM} ${PREFIX}/bin/xv ;\
+ fi
+ @${LN} -sf ${PREFIX}/bin/ja-xv ${PREFIX}/bin/xv
+
+.include <${.CURDIR}/../../graphics/xv/Makefile>