aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2008-09-20 17:59:24 +0800
committernork <nork@FreeBSD.org>2008-09-20 17:59:24 +0800
commit7b1d9f050914f740d009825c6366364ac04c6907 (patch)
treea66e88e557f82cc16cc8d38c3612f393be7d7c5f /japanese
parent0efaf659b58c8dcc5e9d90c597735957b07eee90 (diff)
downloadfreebsd-ports-graphics-7b1d9f050914f740d009825c6366364ac04c6907.tar.gz
freebsd-ports-graphics-7b1d9f050914f740d009825c6366364ac04c6907.tar.zst
freebsd-ports-graphics-7b1d9f050914f740d009825c6366364ac04c6907.zip
Fix crash issue of cannaserver.
Obtained from: NetBSD, Canna CVS Repositry Approved by: portmgr (marcus) Committed at: the 27th EBUG Meeting at Bandai, Niigata, Japan (Powered by Daisuke) Committed with: EBUG Members (hre, karl, daigu, high, mikio, kaw and nork@)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Canna/Makefile2
-rw-r--r--japanese/Canna/files/patch-lib-RK-ncache.c11
-rw-r--r--japanese/canna-lib/Makefile2
-rw-r--r--japanese/canna-lib/files/patch-lib-RK-ncache.c11
-rw-r--r--japanese/canna-server/Makefile2
-rw-r--r--japanese/canna-server/files/patch-lib-RK-ncache.c11
6 files changed, 36 insertions, 3 deletions
diff --git a/japanese/Canna/Makefile b/japanese/Canna/Makefile
index 939e4aa26b9..461d32e52ed 100644
--- a/japanese/Canna/Makefile
+++ b/japanese/Canna/Makefile
@@ -8,7 +8,7 @@
PORTNAME= Canna
PORTVERSION= 3.7p3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR= canna/9565/
diff --git a/japanese/Canna/files/patch-lib-RK-ncache.c b/japanese/Canna/files/patch-lib-RK-ncache.c
new file mode 100644
index 00000000000..1695441e8b3
--- /dev/null
+++ b/japanese/Canna/files/patch-lib-RK-ncache.c
@@ -0,0 +1,11 @@
+--- lib/RK/ncache.c.orig 2003-09-17 17:50:52.000000000 +0900
++++ lib/RK/ncache.c 2008-09-20 01:46:07.000000000 +0900
+@@ -27,7 +27,7 @@
+ #include "RKintern.h"
+
+ #define NCHASH 101
+-#define hash(x) ((int)((x)%NCHASH))
++#define hash(x) ((int)(((unsigned long)(x))%NCHASH))
+
+ static struct ncache Nchash[NCHASH];
+ static struct ncache Ncfree;
diff --git a/japanese/canna-lib/Makefile b/japanese/canna-lib/Makefile
index 939e4aa26b9..461d32e52ed 100644
--- a/japanese/canna-lib/Makefile
+++ b/japanese/canna-lib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= Canna
PORTVERSION= 3.7p3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR= canna/9565/
diff --git a/japanese/canna-lib/files/patch-lib-RK-ncache.c b/japanese/canna-lib/files/patch-lib-RK-ncache.c
new file mode 100644
index 00000000000..1695441e8b3
--- /dev/null
+++ b/japanese/canna-lib/files/patch-lib-RK-ncache.c
@@ -0,0 +1,11 @@
+--- lib/RK/ncache.c.orig 2003-09-17 17:50:52.000000000 +0900
++++ lib/RK/ncache.c 2008-09-20 01:46:07.000000000 +0900
+@@ -27,7 +27,7 @@
+ #include "RKintern.h"
+
+ #define NCHASH 101
+-#define hash(x) ((int)((x)%NCHASH))
++#define hash(x) ((int)(((unsigned long)(x))%NCHASH))
+
+ static struct ncache Nchash[NCHASH];
+ static struct ncache Ncfree;
diff --git a/japanese/canna-server/Makefile b/japanese/canna-server/Makefile
index 939e4aa26b9..461d32e52ed 100644
--- a/japanese/canna-server/Makefile
+++ b/japanese/canna-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME= Canna
PORTVERSION= 3.7p3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR= canna/9565/
diff --git a/japanese/canna-server/files/patch-lib-RK-ncache.c b/japanese/canna-server/files/patch-lib-RK-ncache.c
new file mode 100644
index 00000000000..1695441e8b3
--- /dev/null
+++ b/japanese/canna-server/files/patch-lib-RK-ncache.c
@@ -0,0 +1,11 @@
+--- lib/RK/ncache.c.orig 2003-09-17 17:50:52.000000000 +0900
++++ lib/RK/ncache.c 2008-09-20 01:46:07.000000000 +0900
+@@ -27,7 +27,7 @@
+ #include "RKintern.h"
+
+ #define NCHASH 101
+-#define hash(x) ((int)((x)%NCHASH))
++#define hash(x) ((int)(((unsigned long)(x))%NCHASH))
+
+ static struct ncache Nchash[NCHASH];
+ static struct ncache Ncfree;