aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /japanese
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'japanese')
-rw-r--r--japanese/dserver/Makefile6
-rw-r--r--japanese/oleo/Makefile10
-rw-r--r--japanese/vfxdvi300/Makefile12
-rw-r--r--japanese/xjtext/Makefile10
4 files changed, 19 insertions, 19 deletions
diff --git a/japanese/dserver/Makefile b/japanese/dserver/Makefile
index 4046d72bdd7..39ff856aae4 100644
--- a/japanese/dserver/Makefile
+++ b/japanese/dserver/Makefile
@@ -24,15 +24,15 @@ COMMENT= CDROM dictionary server & clients
RUN_DEPENDS= jless:${PORTSDIR}/japanese/less
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
-
pre-patch:
${PATCH} -d ${WRKSRC}/clients -E < ${DISTDIR}/kenjiro-ndtpd.diff
${PATCH} -d ${WRKSRC}/clients -E < ${DISTDIR}/kenjiro-dictlist.diff
diff --git a/japanese/oleo/Makefile b/japanese/oleo/Makefile
index 054c1f7b4e2..3e1c15035f2 100644
--- a/japanese/oleo/Makefile
+++ b/japanese/oleo/Makefile
@@ -24,17 +24,17 @@ COMMENT= A Spreadsheet Program + Japanese patches
# xmkmf is for configure script, not for USE_IMAKE.
BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake-4
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+GNU_CONFIGURE=yes
+USE_XLIB= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-GNU_CONFIGURE=yes
-USE_XLIB= yes
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/oleo/ja_JP.EUC
diff --git a/japanese/vfxdvi300/Makefile b/japanese/vfxdvi300/Makefile
index 23361b26630..399e5d28cc7 100644
--- a/japanese/vfxdvi300/Makefile
+++ b/japanese/vfxdvi300/Makefile
@@ -30,12 +30,6 @@ COMMENT= DVI Previewer for X. + Japanese patch + vector font support
LIB_DEPENDS= VFlib2.24:${PORTSDIR}/japanese/vflib
RUN_DEPENDS= ${LOCALBASE}/lib/fonts/pk${RESOLUTION}:${PORTSDIR}/print/pkfonts${RESOLUTION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
NO_WRKSUBDIR= yes
USE_IMAKE= yes
XMKMF= xmkmf
@@ -55,6 +49,12 @@ RESOLUTION= 300
.endif
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@(cd ${WRKDIR} ; \
${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/950923.02.Z | uudecode ; \
diff --git a/japanese/xjtext/Makefile b/japanese/xjtext/Makefile
index 1564de79c18..4882108088b 100644
--- a/japanese/xjtext/Makefile
+++ b/japanese/xjtext/Makefile
@@ -15,17 +15,17 @@ DISTNAME= XJTEXT-${PORTVERSION}
MAINTAINER= sada@FreeBSD.org
COMMENT= A text viewer for Japanese virtical writings
+USE_BISON= yes
+USE_GNOME= imlib
+EXAMPLEDIR= ${PREFIX}/share/examples/xjtext
+DOCDIR= ${PREFIX}/share/doc/xjtext
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_BISON= yes
-USE_GNOME= imlib
-EXAMPLEDIR= ${PREFIX}/share/examples/xjtext
-DOCDIR= ${PREFIX}/share/doc/xjtext
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xjtext ${PREFIX}/bin