aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-EPIC
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2004-12-23 19:52:13 +0800
committernork <nork@FreeBSD.org>2004-12-23 19:52:13 +0800
commit28c340a417ca082de0a1ca8b13710a71f3da7c11 (patch)
tree518153ae32e31db8098ee67e5ccd1a8e4725e72f /java/eclipse-EPIC
parentaab65e343213a59be0c263e38a852d5b7493e4fd (diff)
downloadfreebsd-ports-graphics-28c340a417ca082de0a1ca8b13710a71f3da7c11.tar.gz
freebsd-ports-graphics-28c340a417ca082de0a1ca8b13710a71f3da7c11.tar.zst
freebsd-ports-graphics-28c340a417ca082de0a1ca8b13710a71f3da7c11.zip
Add eclipse-EPIC 0.3.0, EPIC adds Perl support to
the Eclipse IDE Framework. PR: ports/74480 Submitted by: tux@pinguru.net
Diffstat (limited to 'java/eclipse-EPIC')
-rw-r--r--java/eclipse-EPIC/Makefile38
-rw-r--r--java/eclipse-EPIC/distinfo2
-rw-r--r--java/eclipse-EPIC/pkg-descr8
3 files changed, 48 insertions, 0 deletions
diff --git a/java/eclipse-EPIC/Makefile b/java/eclipse-EPIC/Makefile
new file mode 100644
index 00000000000..9e00e368bbe
--- /dev/null
+++ b/java/eclipse-EPIC/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: EPIC
+# Date created: 28 Nov 2004
+# Whom: tux@pinguru.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= EPIC
+PORTVERSION= 0.3.0
+CATEGORIES= java editors devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= e-p-i-c
+PKGNAMEPREFIX= eclipse-
+DISTNAME= ${EPIC}_${PORTVERSION}_20040711
+
+MAINTAINER= tux@pinguru.net
+COMMENT= EPIC adds Perl support to the Eclipse IDE Framework
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${EPIC}
+
+EPIC= org.epic.updatesite
+ECLIPSE= ${PREFIX}/eclipse
+
+do-install:
+ @${CP} -r ${WRKSRC}/features/*.jar ${ECLIPSE}/features
+ @${CP} -r ${WRKSRC}/plugins/*.jar ${ECLIPSE}/plugins
+
+post-install:
+ @${FIND} -s ${WRKSRC}/features -name "*.jar" \
+ | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s ${WRKSRC}/plugins -name "*.jar" \
+ | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-EPIC/distinfo b/java/eclipse-EPIC/distinfo
new file mode 100644
index 00000000000..03f6e8f95e1
--- /dev/null
+++ b/java/eclipse-EPIC/distinfo
@@ -0,0 +1,2 @@
+MD5 (org.epic.updatesite_0.3.0_20040711.zip) = 5ab8b866c599bd41f8dcb57564d5bc2d
+SIZE (org.epic.updatesite_0.3.0_20040711.zip) = 2649757
diff --git a/java/eclipse-EPIC/pkg-descr b/java/eclipse-EPIC/pkg-descr
new file mode 100644
index 00000000000..1d55d99a92b
--- /dev/null
+++ b/java/eclipse-EPIC/pkg-descr
@@ -0,0 +1,8 @@
+EPIC is an opensource Perl IDE for the Eclipse platform.
+Features supported are syntax highlighting, on the fly syntax check,
+content assist, perldoc support, source formatter, templating support
+and a Perl debugger.
+A regular expression plugin and support for the eSpell spellchecker
+are also available.
+
+WWW: http://e-p-i-c.sourceforge.net/