aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-ocl
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-07-25 15:05:41 +0800
committerglewis <glewis@FreeBSD.org>2010-07-25 15:05:41 +0800
commit755f1fc00e0c069114f9b1763d37906899f0fb5d (patch)
tree3b5fe85d96df646e47effac87210fc34d6621d1e /java/eclipse-ocl
parentfa4d650179a1f7950c594d101ff9de19916d9958 (diff)
downloadfreebsd-ports-graphics-755f1fc00e0c069114f9b1763d37906899f0fb5d.tar.gz
freebsd-ports-graphics-755f1fc00e0c069114f9b1763d37906899f0fb5d.tar.zst
freebsd-ports-graphics-755f1fc00e0c069114f9b1763d37906899f0fb5d.zip
. Update installation paths for the new version of eclipse.
PR: 148667 Approved by: Veit Jahns <vj562001@yahoo.de> (MAINTAINER)
Diffstat (limited to 'java/eclipse-ocl')
-rw-r--r--java/eclipse-ocl/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
index 0d91af743c0..91c15f1f05e 100644
--- a/java/eclipse-ocl/Makefile
+++ b/java/eclipse-ocl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ocl
DISTVERSION= 1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/modeling/mdt/ocl/downloads/drops/,}
MASTER_SITE_SUBDIR=${DISTVERSION}.0/R200706201142
@@ -19,7 +19,7 @@ MAINTAINER= vj562001@yahoo.de
COMMENT= Implementation of the OCL OMG standard for EMF-based models
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf
+ ${LOCALBASE}/lib/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -29,12 +29,12 @@ JAVA_VERSION= 1.4+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>