aboutsummaryrefslogtreecommitdiffstats
path: root/java/jasmin
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-06-28 19:52:27 +0800
committeritetcu <itetcu@FreeBSD.org>2008-06-28 19:52:27 +0800
commitf1a4113ea4bcf2c5ddadfde4f405ed186ad25023 (patch)
treee8dd9c0b0e09bea4c6c82c0f8c916618c70cd76e /java/jasmin
parent8eaab95799fb865f8fad199b4e18330bbf376a82 (diff)
downloadfreebsd-ports-graphics-f1a4113ea4bcf2c5ddadfde4f405ed186ad25023.tar.gz
freebsd-ports-graphics-f1a4113ea4bcf2c5ddadfde4f405ed186ad25023.tar.zst
freebsd-ports-graphics-f1a4113ea4bcf2c5ddadfde4f405ed186ad25023.zip
- respect NOPORTDOCS and NOPORTEXAMPLES
- fix plist for -DNOPORTDOCS - bump PORTREVISION Prompted by: QA Tindy run Approved by: maintainer timeout on BotMail
Diffstat (limited to 'java/jasmin')
-rw-r--r--java/jasmin/Makefile5
-rw-r--r--java/jasmin/pkg-plist58
2 files changed, 32 insertions, 31 deletions
diff --git a/java/jasmin/Makefile b/java/jasmin/Makefile
index 6bc13ea97d1..6d75ae31697 100644
--- a/java/jasmin/Makefile
+++ b/java/jasmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jasmin
PORTVERSION= 2.3
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= java lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -28,12 +28,13 @@ SUB_FILES= jasmin.sh
do-install:
${INSTALL_DATA} ${WRKSRC}/jasmin.jar ${JAVAJARDIR}
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples ; \
${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/\{} \; ;\
${FIND} . -type f -exec ${INSTALL_DATA} \{} ${EXAMPLESDIR}/\{} \;
+.endif
${INSTALL_SCRIPT} ${WRKDIR}/jasmin.sh ${PREFIX}/bin/jasmin
-
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}
cd ${WRKSRC}/docs ; \
diff --git a/java/jasmin/pkg-plist b/java/jasmin/pkg-plist
index 9860f4dabd5..cc28b71a6e3 100644
--- a/java/jasmin/pkg-plist
+++ b/java/jasmin/pkg-plist
@@ -1,31 +1,31 @@
bin/jasmin
-%%DOCSDIR%%/about.html
-%%DOCSDIR%%/guide.html
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/instructions.html
-%%DOCSDIR%%/jasmin_icon.jpg
-%%DOCSDIR%%/javavm.gif
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/syntax.bnf
-%%EXAMPLESDIR%%/ANewArray.j
-%%EXAMPLESDIR%%/AnInterface.j
-%%EXAMPLESDIR%%/Arrays.j
-%%EXAMPLESDIR%%/Catch.j
-%%EXAMPLESDIR%%/Checkcast.j
-%%EXAMPLESDIR%%/Count.j
-%%EXAMPLESDIR%%/HelloWeb.html
-%%EXAMPLESDIR%%/HelloWeb.j
-%%EXAMPLESDIR%%/HelloWorld.class
-%%EXAMPLESDIR%%/HelloWorld.j
-%%EXAMPLESDIR%%/Implementor.j
-%%EXAMPLESDIR%%/InvokeInterface.j
-%%EXAMPLESDIR%%/MultiANewArray.j
-%%EXAMPLESDIR%%/MultiArrays.j
-%%EXAMPLESDIR%%/NewArray.j
-%%EXAMPLESDIR%%/Switch.j
-%%EXAMPLESDIR%%/Uncaught.j
-%%EXAMPLESDIR%%/VerifyTest.j
-%%EXAMPLESDIR%%/VerifyTest1.j
+%%PORTDOCS%%%%DOCSDIR%%/about.html
+%%PORTDOCS%%%%DOCSDIR%%/guide.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/instructions.html
+%%PORTDOCS%%%%DOCSDIR%%/jasmin_icon.jpg
+%%PORTDOCS%%%%DOCSDIR%%/javavm.gif
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/syntax.bnf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ANewArray.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/AnInterface.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arrays.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Catch.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Checkcast.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Count.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWeb.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWeb.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWorld.class
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWorld.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Implementor.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/InvokeInterface.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MultiANewArray.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MultiArrays.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NewArray.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Switch.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Uncaught.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/VerifyTest.j
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/VerifyTest1.j
share/java/classes/jasmin.jar
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%