aboutsummaryrefslogtreecommitdiffstats
path: root/java/jikes
diff options
context:
space:
mode:
authordillon <dillon@FreeBSD.org>1998-12-16 14:03:37 +0800
committerdillon <dillon@FreeBSD.org>1998-12-16 14:03:37 +0800
commit4a211fcb3d03657be3b98a5c764dc2fc4d59262f (patch)
treeece4945076e18f7d87a2680bf6dbda04fc013ba0 /java/jikes
parent6ef7653e38c58edaf072bc606698b5f3890c5517 (diff)
downloadfreebsd-ports-graphics-4a211fcb3d03657be3b98a5c764dc2fc4d59262f.tar.gz
freebsd-ports-graphics-4a211fcb3d03657be3b98a5c764dc2fc4d59262f.tar.zst
freebsd-ports-graphics-4a211fcb3d03657be3b98a5c764dc2fc4d59262f.zip
Create ports patches for patches found on ftp site maintained by
Vadim Zaliva. See Makefile comments. * add extended version info to 'jikes -h' so we can track bugs with the port * unused variables warnings * patch for array cloning bug * patch for makedepend bug * patch for ANSI fp handling (i.e. avoid faulting out on divide by 0 an such).
Diffstat (limited to 'java/jikes')
-rw-r--r--java/jikes/Makefile27
-rw-r--r--java/jikes/files/patch-aa11
2 files changed, 37 insertions, 1 deletions
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 832bc3ce1c3..7270cb9ed11 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -3,7 +3,32 @@
# Date created: 09 December 1998
# Whom: Matthew Dillon <dillon@backplane.com>
#
-# $Id: Makefile,v 1.2 1998/12/10 20:29:37 dillon Exp $
+# UNOFFICIAL PATCH SOURCES:
+# ftp://ftp.crocodile.org/pub/jikes/
+# maintained by Vadim Zaliva
+#
+# PATCH INFO: (note: patches had to be regenerated, the patch files in
+# patches/ are not exactly the same as the ftp source)
+#
+# patches/patch-aa
+# patch to compile under FreeBSD (local)
+#
+# patches/patch-ab
+# ftp://ftp.crocodile.org/pub/jikes/divide0.patch
+#
+# patches/patch-ac
+# ftp://ftp.crocodile.org/pub/jikes/jikes-0.41-warnings1.patch
+#
+# patches/patch-ad
+# ftp://ftp.crocodile.org/pub/jikes/jikes-array-clone.patch
+#
+# (solaris compiler patch not required)
+# ftp://ftp.crocodile.org/pub/jikes/jikes-solaris2.6-gcc2.8.1.patch
+#
+# patches/patch-ae
+# ftp://ftp.crocodile.org/pub/jikes/jikes.makedepend.patch
+#
+# $Id: Makefile,v 1.3 1998/12/16 00:12:24 steve Exp $
#
DISTNAME= jikes-0.41
diff --git a/java/jikes/files/patch-aa b/java/jikes/files/patch-aa
index 6713c7bb4f2..649e3bf7b55 100644
--- a/java/jikes/files/patch-aa
+++ b/java/jikes/files/patch-aa
@@ -25,3 +25,14 @@
OBJECTS=jikes.$(O) scanner.$(O) code.$(O) zip.$(O) unzip.$(O) ast.$(O) diagnose.$(O) \
parser.$(O) lpginput.$(O) lcase.$(O) javaact.$(O) error.$(O) set.$(O) symbol.$(O) \
+--- jikes/src/jikes.cpp.orig Tue Dec 15 21:46:33 1998
++++ jikes/src/jikes.cpp Tue Dec 15 21:47:17 1998
+@@ -75,7 +75,7 @@
+ << "+U do full dependence check including Zip and Jar files\n"
+ << "+V generate veracious listing\n"
+ << "+Z treat cautions as errors\n"
+- << "\nVersion 0.41 (01 Dec 98)"
++ << "\nVersion 0.41-FreeBSD-ae (15 Dec 98)"
+ << " by Philippe Charles and David Shields, IBM Research.\n";
+ cerr << "Please report problems to shields@watson.ibm.com.\n" ;
+ cerr << "or via browser at http://www.ibm.com/research/jikes\n";