aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2003-07-15 04:54:08 +0800
committerolgeni <olgeni@FreeBSD.org>2003-07-15 04:54:08 +0800
commit2f145c2cb043dcbd9196c3f1c691c4363c5be32c (patch)
tree148ae842f068f6ce5343590c11088f5b9fa40917 /java
parent99b86e2995f67870e85c14250a0f28b291636b03 (diff)
downloadfreebsd-ports-graphics-2f145c2cb043dcbd9196c3f1c691c4363c5be32c.tar.gz
freebsd-ports-graphics-2f145c2cb043dcbd9196c3f1c691c4363c5be32c.tar.zst
freebsd-ports-graphics-2f145c2cb043dcbd9196c3f1c691c4363c5be32c.zip
Add ANT_OPTS to MAKE_ENV to expand the java heap at runtime.
It may happen that ant does not have sufficient heap to zip the plugins during installation. Obtained from: Jan Schulz (from the eclipse.tools.jdt newsgroup) Verified by: Edmond Nolan <eddie@eddienolan.com>
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index f07812b71c2..9d1da442aa8 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -32,6 +32,7 @@ MAKE_ARGS= ECLIPSE_BUILD=${ECLIPSE_BUILD} \
ECLIPSE_OS=${ECLIPSE_OS} \
ECLIPSE_WS=${ECLIPSE_WS} \
JAVA_HOME=${JAVA_HOME}
+MAKE_ENV= ANT_OPTS=-Xmx256M
ECLIPSE_BUILD= 2135
ECLIPSE_OS= freebsd