aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-09-03 14:21:24 +0800
committerkris <kris@FreeBSD.org>2006-09-03 14:21:24 +0800
commit635eb2114b8a99cd18ad95353c04deca97391ddc (patch)
tree1791005856840d4f1f115659d88589472df1836a /java
parent6dc367398ff49a0ed37511217eb6a2501ab825fa (diff)
downloadfreebsd-ports-graphics-635eb2114b8a99cd18ad95353c04deca97391ddc.tar.gz
freebsd-ports-graphics-635eb2114b8a99cd18ad95353c04deca97391ddc.tar.zst
freebsd-ports-graphics-635eb2114b8a99cd18ad95353c04deca97391ddc.zip
Allow package builds
Diffstat (limited to 'java')
-rw-r--r--java/collections/Makefile2
-rw-r--r--java/infobus/Makefile2
-rw-r--r--java/jaf/Makefile2
-rw-r--r--java/javamail/Makefile2
-rw-r--r--java/jdk13-doc/Makefile2
-rw-r--r--java/jdk14-doc/Makefile2
-rw-r--r--java/jdk15-doc/Makefile2
-rw-r--r--java/jsdk/Makefile2
-rw-r--r--java/netbeans/Makefile2
-rw-r--r--java/netbeans3/Makefile2
-rw-r--r--java/netbeans4/Makefile2
-rw-r--r--java/netbeans5/Makefile2
-rw-r--r--java/netbeans55/Makefile2
-rw-r--r--java/netbeans61/Makefile2
14 files changed, 14 insertions, 14 deletions
diff --git a/java/collections/Makefile b/java/collections/Makefile
index 7464e43d252..00ffbf1f9ec 100644
--- a/java/collections/Makefile
+++ b/java/collections/Makefile
@@ -30,7 +30,7 @@ JARFILE= collections.jar
PLIST_FILES+= %%JAVAJARDIR%%/${JARFILE}
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
DOWNLOAD_URL= "http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=7264-collections-1.1-oth-JPR&SiteId=JSC&TransactionId=noreg"
IGNORE= "You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again"
.endif
diff --git a/java/infobus/Makefile b/java/infobus/Makefile
index 9ccbf83f73e..36f27fa7958 100644
--- a/java/infobus/Makefile
+++ b/java/infobus/Makefile
@@ -29,7 +29,7 @@ PORTDOCS= *
.endif
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= You must manually fetch the distribution from http://java.sun.com/products/archive/javabeans/infobus/downloads.html and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/jaf/Makefile b/java/jaf/Makefile
index a5d9bf19cd8..efd5da0721b 100644
--- a/java/jaf/Makefile
+++ b/java/jaf/Makefile
@@ -32,7 +32,7 @@ PORTDOCS= ${DOCFILES1} ${DOCFILES2}
PLIST_FILES= %%JAVAJARDIR%%/activation.jar
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= You must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/javamail/Makefile b/java/javamail/Makefile
index 30586261c0d..1ae06c04885 100644
--- a/java/javamail/Makefile
+++ b/java/javamail/Makefile
@@ -37,7 +37,7 @@ JARFILES= mail.jar imap.jar mailapi.jar pop3.jar smtp.jar
PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= You must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/jdk13-doc/Makefile b/java/jdk13-doc/Makefile
index 540449eb376..2b74c9e1f40 100644
--- a/java/jdk13-doc/Makefile
+++ b/java/jdk13-doc/Makefile
@@ -31,7 +31,7 @@ PORTDOCS= api guide images index.html relnotes tooldocs
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/jdk14-doc/Makefile b/java/jdk14-doc/Makefile
index 47994c783b6..63d3ef36618 100644
--- a/java/jdk14-doc/Makefile
+++ b/java/jdk14-doc/Makefile
@@ -31,7 +31,7 @@ PORTDOCS= api guide images index.html install-notes relnotes tooldocs
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/jdk15-doc/Makefile b/java/jdk15-doc/Makefile
index 3d7ae690354..5865b17d239 100644
--- a/java/jdk15-doc/Makefile
+++ b/java/jdk15-doc/Makefile
@@ -32,7 +32,7 @@ PORTDOCS= api guide images index.html relnotes tooldocs
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/jsdk/Makefile b/java/jsdk/Makefile
index 0299c64a959..74fcf6d500a 100644
--- a/java/jsdk/Makefile
+++ b/java/jsdk/Makefile
@@ -25,7 +25,7 @@ RESTRICTED= "Sun has a funky license for this software; no commercial use"
WRKSRC= ${WRKDIR}/JSDK2.0
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
+.if defined(BATCH)
IGNORE= "Should be fetched manually"
.endif
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index 2fc4dcb3a44..a2daa7fe466 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?type=5.0&p=1&a=bs
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans3/Makefile b/java/netbeans3/Makefile
index 4cce702de5f..211833779cd 100644
--- a/java/netbeans3/Makefile
+++ b/java/netbeans3/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.org/download/release36/promoted/FCS/release36
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans4/Makefile b/java/netbeans4/Makefile
index cfc3acc67d5..3e9623091a5 100644
--- a/java/netbeans4/Makefile
+++ b/java/netbeans4/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?p=1&a=bd&os=1&lan
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans5/Makefile b/java/netbeans5/Makefile
index cfc3acc67d5..3e9623091a5 100644
--- a/java/netbeans5/Makefile
+++ b/java/netbeans5/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?p=1&a=bd&os=1&lan
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans55/Makefile b/java/netbeans55/Makefile
index cfc3acc67d5..3e9623091a5 100644
--- a/java/netbeans55/Makefile
+++ b/java/netbeans55/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?p=1&a=bd&os=1&lan
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans61/Makefile b/java/netbeans61/Makefile
index 2fc4dcb3a44..a2daa7fe466 100644
--- a/java/netbeans61/Makefile
+++ b/java/netbeans61/Makefile
@@ -26,7 +26,7 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?type=5.0&p=1&a=bs
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif