aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-08-01 01:51:08 +0800
committerglewis <glewis@FreeBSD.org>2010-08-01 01:51:08 +0800
commitc2616d54977971a8afbe6cbb2ba30b2ee74db1be (patch)
treec607bf563cf61af27d8122cb0e69dc7f47fd0483 /java
parentb67ec69dc92f2f89410aeddd67baa8133770e360 (diff)
downloadfreebsd-ports-graphics-c2616d54977971a8afbe6cbb2ba30b2ee74db1be.tar.gz
freebsd-ports-graphics-c2616d54977971a8afbe6cbb2ba30b2ee74db1be.tar.zst
freebsd-ports-graphics-c2616d54977971a8afbe6cbb2ba30b2ee74db1be.zip
. Update the installation paths for the new version of eclipse
PR: 148668 Approved by: Sutra Zhou <zhoushuqun@gmail.com> (maintainer)
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-propedit/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-propedit/Makefile b/java/eclipse-propedit/Makefile
index 551a6d204d4..0cb51d10297 100644
--- a/java/eclipse-propedit/Makefile
+++ b/java/eclipse-propedit/Makefile
@@ -28,12 +28,12 @@ JAVA_VERSION= 1.4+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>