aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-08-01 02:03:52 +0800
committerglewis <glewis@FreeBSD.org>2010-08-01 02:03:52 +0800
commiteeed3d585e5c64fa3bf3ba8291e3b9aa06f22103 (patch)
treeb4a083e760d64e2bda37547ae0935097134da808 /java
parent79d03299e652724b5e8cc1ca6326fbde1c8e0077 (diff)
downloadfreebsd-ports-graphics-eeed3d585e5c64fa3bf3ba8291e3b9aa06f22103.tar.gz
freebsd-ports-graphics-eeed3d585e5c64fa3bf3ba8291e3b9aa06f22103.tar.zst
freebsd-ports-graphics-eeed3d585e5c64fa3bf3ba8291e3b9aa06f22103.zip
. Update installation path for the new version of eclipse.
PR: 148665 Approved by: maintainer timeout
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-lomboz/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
index 39f8f5d4930..b1b8b3accc5 100644
--- a/java/eclipse-lomboz/Makefile
+++ b/java/eclipse-lomboz/Makefile
@@ -31,12 +31,12 @@ JAVA_VERSION= 1.4+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>