aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-28 06:28:55 +0800
committermiwi <miwi@FreeBSD.org>2009-07-28 06:28:55 +0800
commitf73acf17d061d5f6e022d41e95ac97002c169cc5 (patch)
tree57c00921f5a846a24af7e1d29623361ec2824d21 /java
parent242f0afded019f7f4fd689295a1be1fd99eb78db (diff)
downloadfreebsd-ports-graphics-f73acf17d061d5f6e022d41e95ac97002c169cc5.tar.gz
freebsd-ports-graphics-f73acf17d061d5f6e022d41e95ac97002c169cc5.tar.zst
freebsd-ports-graphics-f73acf17d061d5f6e022d41e95ac97002c169cc5.zip
- Activat support for getGeneratedKeys() for prepared statements, which is
supported as well as the non-prepared statement case, but it was currently returning a not implemented exception. PR: 137001 Submitted by: Lapo Luchini <lapo@lapo.it> (maintainer)
Diffstat (limited to 'java')
-rw-r--r--java/sqlitejdbc/Makefile1
-rw-r--r--java/sqlitejdbc/files/patch-src_org_sqlite_Conn.java14
2 files changed, 15 insertions, 0 deletions
diff --git a/java/sqlitejdbc/Makefile b/java/sqlitejdbc/Makefile
index 6c686b92a8c..c1aed2e69c3 100644
--- a/java/sqlitejdbc/Makefile
+++ b/java/sqlitejdbc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlitejdbc
PORTVERSION= 056
+PORTREVISION= 1
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -src
CATEGORIES= java databases
diff --git a/java/sqlitejdbc/files/patch-src_org_sqlite_Conn.java b/java/sqlitejdbc/files/patch-src_org_sqlite_Conn.java
new file mode 100644
index 00000000000..d5bb495d95b
--- /dev/null
+++ b/java/sqlitejdbc/files/patch-src_org_sqlite_Conn.java
@@ -0,0 +1,14 @@
+--- src/org/sqlite/Conn.java.orig 2009-07-22 18:33:46.000000000 +0200
++++ src/org/sqlite/Conn.java 2009-07-22 18:33:53.000000000 +0200
+@@ -214,7 +214,10 @@ class Conn implements Connection
+ ResultSet.CONCUR_READ_ONLY);
+ }
+ public PreparedStatement prepareStatement(String sql, int autoC)
+- throws SQLException { throw new SQLException("NYI"); }
++ throws SQLException {
++ return prepareStatement(sql, ResultSet.TYPE_FORWARD_ONLY,
++ ResultSet.CONCUR_READ_ONLY);
++ }
+ public PreparedStatement prepareStatement(String sql, int[] colInds)
+ throws SQLException { throw new SQLException("NYI"); }
+ public PreparedStatement prepareStatement(String sql, String[]