aboutsummaryrefslogtreecommitdiffstats
path: root/korean/ghostscript-gnu-korfont/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-04-28 21:03:16 +0800
committerhrs <hrs@FreeBSD.org>2007-04-28 21:03:16 +0800
commited1f4c541c95c56d099b48bb52ff53d5c34806bb (patch)
tree809af14cbb9cad7d1a9b177b46be43628c281326 /korean/ghostscript-gnu-korfont/Makefile
parent670b9382a20f633d6c0cb952c05cccabeb8a118f (diff)
downloadfreebsd-ports-graphics-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.tar.gz
freebsd-ports-graphics-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.tar.zst
freebsd-ports-graphics-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.zip
Cleanup ghostscript-gnu-commfont and related CJK font support meta ports.
Changes include: - Set WITH_GHOSTSCRIPT_GNU forcibly. - Use PostScript virtual fonts to handle CJK CID/TT-CID emulated fonts. CIDFnmap still works but when a font is both in Resource/Font or Resource/CIDFont and in CIDFnmap, the former entry will be used. For the actual font mapping, see files in Resource/CIDFont/*. So, note that you need to remove (or rename) the virtual font if you use CIDFnmap for the moment. This is still a transitional measure and more consistent font management thoughout the ports collection should be added later. This is just an internal structural change; default font mapping has not been changed. - Add Chinese font support to print/gsfonts (but no dependency added).
Diffstat (limited to 'korean/ghostscript-gnu-korfont/Makefile')
-rw-r--r--korean/ghostscript-gnu-korfont/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/korean/ghostscript-gnu-korfont/Makefile b/korean/ghostscript-gnu-korfont/Makefile
index 14c57f42f9f..c9883a21d71 100644
--- a/korean/ghostscript-gnu-korfont/Makefile
+++ b/korean/ghostscript-gnu-korfont/Makefile
@@ -5,12 +5,26 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../../print/ghostscript-gnu-commfont
-PORTREVISION= 1
+PORTNAME= ghostscript-gnu-korfont
+PORTVERSION= 7.07
+PORTREVISION= 2
+CATEGORIES= korean print
+MASTER_SITES= # empty
+DISTFILES= # empty
-.undef COMMFONT
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Korean font support for GNU Ghostscript
-KORFONT= yes
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/CIDFont/Munhwa-Regular:${PORTSDIR}/korean/munhwafonts-cid \
+ ${LOCALBASE}/share/ghostscript/Resource/CIDFont/HYSMyeongJo-Medium:${PORTSDIR}/print/ghostscript-gnu-commfont
-.include "${MASTERDIR}/Makefile.common"
+# set these forcibly
+WITH_GHOSTSCRIPT_GNU= yes
+USE_GHOSTSCRIPT_RUN= yes
+NO_BUILD= yes
+DEPENDS_ARGS+= -DA4
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>