aboutsummaryrefslogtreecommitdiffstats
path: root/korean/hanIM/Makefile
diff options
context:
space:
mode:
authorcjh <cjh@FreeBSD.org>2000-07-05 02:25:03 +0800
committercjh <cjh@FreeBSD.org>2000-07-05 02:25:03 +0800
commite985ebb55756dc95c855cf4b552a2704549bb8cd (patch)
tree752b45e69101e0b2edc430971000bf08b686068e /korean/hanIM/Makefile
parent300e9807bacba7ba0a041dd6503d425e33883b6a (diff)
downloadfreebsd-ports-graphics-e985ebb55756dc95c855cf4b552a2704549bb8cd.tar.gz
freebsd-ports-graphics-e985ebb55756dc95c855cf4b552a2704549bb8cd.tar.zst
freebsd-ports-graphics-e985ebb55756dc95c855cf4b552a2704549bb8cd.zip
hanIM is now open source. This ports is changed to compile hanIM!
License is not clear so I will not touch LEGAL.
Diffstat (limited to 'korean/hanIM/Makefile')
-rw-r--r--korean/hanIM/Makefile68
1 files changed, 9 insertions, 59 deletions
diff --git a/korean/hanIM/Makefile b/korean/hanIM/Makefile
index 6a746e86354..c868bf0a8d1 100644
--- a/korean/hanIM/Makefile
+++ b/korean/hanIM/Makefile
@@ -6,68 +6,21 @@
#
PORTNAME= hanIM
-PORTVERSION= 1.1b
-CATEGORIES= korean x11 linux
-MASTER_SITES= ftp://www.mizi.co.kr/pub/hanIM/ \
- ftp://ftp.kr.freebsd.org/pub/FreeBSD-kr/distfiles/
-DISTNAME= hanIM-${PORTVERSION}-${HANIM_VER_PL}.i386
-EXTRACT_SUFX= .rpm
+PORTVERSION= 1.2.1
+CATEGORIES= korean x11
+MASTER_SITES= ftp://ftp.mizi.com/pub/hanIM/
MAINTAINER= cjh@kr.freebsd.org
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/misc/rpm
-RUN_DEPENDS= ${PREFIX}/lib/X11/fonts/local/mzgt16h1.pcf.gz:${PORTSDIR}/korean/mizifont \
- /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
- /compat/linux/usr/share/locale/ko/LC_MESSAGES/SYS_LC_MESSAGES:${PORTSDIR}/korean/linux_locale
+RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/local/gulim12.pcf.gz:${PORTSDIR}/korean/baekmukfonts-bdf
-NO_CDROM= "Not a free software"
+USE_IMAKE= YES
+WRKSRC= ${WRKDIR}/hanIM
-USE_X_PREFIX= yes
-NO_WRKSUBDIR= yes
-STRIP=
-
-RPM2CPIO= rpm2cpio
-CPIO= /usr/bin/cpio
-CPIO_OPT= -i --make-directories
-
-HANIM_VER_PL= glibc2.0.7-1
-
-do-extract:
- @${RM} -rf ${WRKDIR} && \
- ${MKDIR} ${WRKDIR} && \
- cd ${WRKDIR} && \
- ${RPM2CPIO} ${_DISTDIR}/${DISTFILES} | ${CPIO} ${CPIO_OPT}
-
-do-build:
- # documents & samples
- ${RM} ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/*.orig
- # dirty workaround. you should delete compiled garbages!
- ${RM} ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/.#* \
- ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/*.o \
- ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/asample \
- ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/overspot \
- ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/samples/rootwin
-
-do-install:
- # binary
- ${INSTALL_PROGRAM} ${WRKDIR}/usr/X11R6/bin/hanIM ${PREFIX}/bin/
-
- # application defaults
- ${INSTALL_DATA} ${WRKDIR}/usr/X11R6/lib/X11/app-defaults/HanIM \
- ${PREFIX}/lib/X11/app-defaults/
-
- # help files
- ${MKDIR} ${PREFIX}/lib/X11/hanIM/help
- ${INSTALL_DATA} ${WRKDIR}/usr/X11R6/lib/X11/hanIM/*.tbl \
- ${PREFIX}/lib/X11/hanIM/
- ${INSTALL_DATA} ${WRKDIR}/usr/X11R6/lib/X11/hanIM/help/* \
- ${PREFIX}/lib/X11/hanIM/help/
-
- # documents & samples
+post-install:
${MKDIR} ${PREFIX}/share/doc/hanIM
- ${CP} -r ${WRKDIR}/usr/doc/hanIM-${PORTVERSION}/* \
- ${PREFIX}/share/doc/hanIM
-
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/LICENSE \
+ ${PREFIX}/share/doc/hanIM/
# patch XLC_LOCALE for ko_KR.EUC(harmless)
if [ -f ${PREFIX}/lib/X11/locale/ko/XLC_LOCALE ]; then \
${MV} -f ${PREFIX}/lib/X11/locale/ko/XLC_LOCALE \
@@ -78,7 +31,4 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/XLC_LOCALE \
${PREFIX}/share/doc/hanIM/
-post-install:
- @${CAT} ${PKGDIR}/MESSAGE
-
.include <bsd.port.mk>