aboutsummaryrefslogtreecommitdiffstats
path: root/korean
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-07-05 05:16:07 +0800
committersteve <steve@FreeBSD.org>1999-07-05 05:16:07 +0800
commitf5fa2ff2d8bb7b52ff20a4506bbec8d634fa5ef2 (patch)
tree4130554cb66a9423dcebc70ef542a2e9726ecf89 /korean
parent3e9ca882b578ab4219ab90e471a5808c3f26e4de (diff)
downloadfreebsd-ports-graphics-f5fa2ff2d8bb7b52ff20a4506bbec8d634fa5ef2.tar.gz
freebsd-ports-graphics-f5fa2ff2d8bb7b52ff20a4506bbec8d634fa5ef2.tar.zst
freebsd-ports-graphics-f5fa2ff2d8bb7b52ff20a4506bbec8d634fa5ef2.zip
Fix build for ELF.
Diffstat (limited to 'korean')
-rw-r--r--korean/pine/files/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/korean/pine/files/Makefile b/korean/pine/files/Makefile
index 2874cc1f71e..eed2de22fbc 100644
--- a/korean/pine/files/Makefile
+++ b/korean/pine/files/Makefile
@@ -1,7 +1,14 @@
+.if ${PORTOBJFORMAT} == "elf"
+SHLIB= libpico.so.1
+.else
+SHLIB= libpico.so.1.3
+.endif
+
all:
./build bsf
install:
- install -c -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} bin/libpico.so.1.3 ${PREFIX}/lib/libpico.so.1.3
+ install -c -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} pico/${SHLIB} ${PREFIX}/lib
+ ln -sf ${SHLIB} ${PREFIX}/lib/libpico.so
/sbin/ldconfig -m ${PREFIX}/lib
install -c -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} bin/pico ${PREFIX}/bin/pico
install -c -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} bin/pilot ${PREFIX}/bin/pilot
eebsd-ports-graphics/commit/net-im?id=0fd5b9bd518b69d4856a581455a159b37cedcc32'>Update to 0.76. For a list of what's new and exciting, see:marcus2004-04-059-517/+126 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-0514-9/+14 * - Update to version 0.9.3 which adds support for Yahoo! and LifeJournalmarkus2004-04-0210-166/+188 * - Update to version 7.2.9.4krion2004-04-022-4/+3 * - Fix MSN nickname display problempav2004-04-022-0/+17 * - Remove USE_SIZE knobkrion2004-04-013-3/+0 * SIZEify (maintainer timeout)trevor2004-03-3126-0/+26 * - Use USE_ICONV knobkrion2004-03-317-10/+7 * - SIZEifymarkus2004-03-292-0/+2 * - Update to 4.9.11pav2004-03-287-24/+53 * Unbreak INDEX building by adding PORTSDIR variable to RUN_DEPENDS.edwin2004-03-271-1/+1 * - Fix breakage, set default hardcoded nowdinoex2004-03-271-1/+1 * - make PKGNAMESUFFIX more flexibledinoex2004-03-273-12/+10 * Detection of OpenLDAP was broken. Fix it.demon2004-03-261-1/+1 * Add pebrot-0.8.5.kevlo2004-03-264-0/+61 * Fix gaim's name resolution on 64-bit platforms.marcus2004-03-262-20/+24 * - Reset maintainer to ports@FreeBSD.org, thank you Anders forkrion2004-03-251-1/+1 * Update to 0.7.4.marcus2004-03-213-5/+5 * SIZEifyerwin2004-03-201-0/+1 * SIZEifymarcus2004-03-191-0/+1 * Update to 0.7.3.marcus2004-03-193-3/+4 * Add size data.trevor2004-03-191-0/+1 * Chase the gnutls shared lib version.marcus2004-03-191-1/+1 * Add size data, approved by maintainers.trevor2004-03-191-0/+1 * Add size data, approved by maintainers.trevor2004-03-193-0/+3 * - Update to 0.16pav2004-03-182-5/+4 * - Add/update WWW lines for Imendio.com projectspav2004-03-182-1/+3 * - Add SIZE to GNOME portspav2004-03-184-0/+4 * BROKEN: Does not compile with qt 3.3kris2004-03-181-0/+2 * Add SIZE data.perky2004-03-183-0/+3 * E-mail to the maintainer bounced:trevor2004-03-181-1/+1 * SIZEify.trevor2004-03-181-0/+1 * Chase the new location of libXft.marcus2004-03-171-1/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-1411-11/+11 * - Update to 0.90pav2004-03-145-169/+404 * - Fix post-install targetkrion2004-03-141-3/+2 * - Chase libraries because of tcllib update from December.krion2004-03-141-8/+4 * add newsbot 0.4.5ijliao2004-03-124-0/+57 * Date: Wed, 10 Mar 2004 23:30:56 -0800 (PST)edwin2004-03-121-1/+1 * Save from destruction by updating to 0.5.3 and unbreaking.linimon2004-03-053-7/+4 * - rpm2cpio.pl need to be EXTRACT_DEPENDS otherwise it will not workpav2004-03-021-1/+1 * The Perl module was broken in gaim since perl.h defined STATIC whichmarcus2004-02-282-1/+21 * Make portlint happy.clement2004-02-271-1/+1 * Remove qmake from RUN_DEPENDS in x11-toolkits/qt32 and chase ports whichlofi2004-02-271-0/+2 * - add CONFLICTSdinoex2004-02-251-0/+3 * BROKEN on !i386: Does not compilekris2004-02-251-1/+7 * BROKEN on !i386: Does not compilekris2004-02-241-1/+7 * Change my email address.markus2004-02-242-2/+2 * Update to version 2.0 stable 2.demon2004-02-223-9/+10 * Rename WITH_PGSQL knob to WITH_POSTGRESQL to be consistent with other ports.demon2004-02-221-5/+5 * This port is scheduled for removal on April 21 if it is still broken atkris2004-02-221-0/+2 * Reset bouncing maintainer addresskris2004-02-221-1/+1 * Utilize the EXPIRATION_DATE tag for these ports scheduled for removal.kris2004-02-221-1/+2 * Fix dependencies after KDE 3.2 updatearved2004-02-202-4/+4 * BROKEN: Does not compile. This port is scheduled for removal on April 19kris2004-02-191-0/+4 * FORBIDDEN on 5.x: links against conflicting thread librarieskris2004-02-191-1/+7 * - use PTHREAD_CFLAGS and PTHREAD_LIBS everywheredinoex2004-02-171-6/+4 * FORBIDDEN on 502102: does not respect PTHREAD_{CFLAGS,LIBS}kris2004-02-171-0/+5 * Fix build on non-i386 arch.linimon2004-02-137-4/+1112 * Use intlhack to fix the build on 4.X.marcus2004-02-131-1/+1 * Update to 0.7.2.marcus2004-02-123-3/+7 * Update to 1.29erwin2004-02-102-3/+10 * The last commit lost previously applied security fixes. Back it out,nectar2004-02-102-140/+256 * Correct the location of OpenSSL.demon2004-02-091-1/+2 * Fix the recent connectivity problems with Yahoo!.marcus2004-02-082-250/+140 * BROKEN: Broken dependencieskris2004-02-081-0/+2 * USE_SIZEifylioux2004-02-088-0/+8 * This port is also broken on 4.x, and will be removed after April 7kris2004-02-081-5/+2 * Upgrade to 1.4.2; fixes special characters not displaying correctly inlinimon2004-02-072-3/+2 * BROKEN on 5.x: Broken pkg-plistkris2004-02-071-1/+7 * Use PLIST_FILES (bento-tested, marcus-reviewed).trevor2004-02-0610-5/+5 * Use PLIST_FILES.trevor2004-02-062-1/+1 * Upgrade to version 2.3.1 which provides updates to authentication,mharo2004-02-042-3/+3 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-0437-5/+37 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-3/+3 * - Update to 0.9.7pav2004-02-022-6/+3 * - Update to version which supports new Yahoo's chat protocolkrion2004-02-022-3/+5 * - Update to version 0.4.6krion2004-02-015-58/+61 * - SIZEifykrion2004-01-306-0/+6 * - Fix build (rpm2cpio port now installs rpm2cpio.pl)pav2004-01-301-2/+2 * SIZEify.trevor2004-01-309-0/+9 * Fix broken port by update to latest 0.9.6b version.osa2004-01-298-444/+518 * Correct a regression introduced in the previous security fix thatnectar2004-01-292-8/+9 * Bump PORTREVISION due to the previous commit.demon2004-01-281-1/+1 * RUN_DEPEND on security/qca-tls to enable connection to jabber server over SSL.demon2004-01-281-0/+2 * Patch almost a dozen vulnerabilities, seenectar2004-01-264-4/+426 * Update to 0.15.1.marcus2004-01-252-2/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-1/+1 * - Update to version 0.7.4krion2004-01-234-12/+4 * Update to 0.7.1.marcus2004-01-233-6/+2 * Use the CPIO macro defined in bsd.port.mk.trevor2004-01-221-1/+1 * Use the SORT macro from bsd.port.mk.trevor2004-01-222-3/+1 * Update to 0.7.marcus2004-01-224-19/+12 * Update to 0.15.marcus2004-01-223-6/+8 * - Update to version 0.4.11krion2004-01-216-4/+6 * Apply maintainer-sanctioned fix fir the !WITH_MULTIBYTE case.sheldonh2004-01-191-3/+3 * Unbreak the !WITH_MULTIBYTE case, where script for the pre-patch targetsheldonh2004-01-191-3/+3 * Update maintainer's email address (prompted by detailed autoreply tolinimon2004-01-191-1/+1 * - Update from 4.9.9 to 4.9.10clement2004-01-185-23/+20 * Specify the location of OpenSSL.demon2004-01-151-0/+1 * - Fix build on -STABLEclement2004-01-142-0/+2 * Fix a regression in the upgrade to gaim 0.75: sscanf() was called withnectar2004-01-142-0/+29 * - Update to version 7.2.9.2krion2004-01-132-2/+2 * Revert last night's distinfo commit. They rerolled the distfile again, andmarcus2004-01-121-1/+1 * - remove dependency on gmakepetef2004-01-122-7/+60 * Looks like 0.75 was respun. The differences are superficial. The NEWS filemarcus2004-01-112-3/+2 * Update to 0.75.marcus2004-01-115-54/+13 * Create directories for jabberd data files with more secure permissions.demon2004-01-091-1/+1 * Pass maintainership to Eugene Ossintsev <eugos@gmx.net>.demon2004-01-091-1/+4 * - Move everybuddy to ayttm, and update to version 0.4.5krion2004-01-096-96/+152 * Update to version 0.9.1;demon2004-01-076-221/+215 * - Tarball was rerolled by developers, new version doesn'tkrion2004-01-072-2/+2 * - Update to version 0.7.3krion2004-01-064-13/+3 * - Update to 2.3.0pav2004-01-043-8/+8 * Install scripts for DB creation for MySQL and PostgreSQL.demon2004-01-022-0/+6 * Put datafiles in /var/jabber directory.demon2004-01-013-1/+8 * Eliminate the evidence that I stole this file from net/jabber port.demon2004-01-011-7/+17 * Set the appropriate permissions for config files;demon2004-01-011-3/+11 * Do delete config files if they were not changed after installation.demon2004-01-011-0/+9 * Remind users about 'jabber' group, too.demon2004-01-011-0/+4 * Compile with debug messages.demon2003-12-311-1/+2 * Install startup script jabberd.sh.demon2003-12-315-0/+87 * Add WITH_PGSQL knob;demon2003-12-302-21/+32 * - Fix build with x11-toolkits/qt32krion2003-12-303-4/+75